Composer安装报错,最好是更换源。

 

composer create-project --prefer-dist laravel/laravel socket "5.8.*"

 报错1

Failed to decode response: zlib_decode(): data error
Retrying with degraded mode, check https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for more info

 报错2 

Failed, trying the next URL (0: zlib_decode(): data error)Downloading (100%) 

 报错3 

Failed to download league/flysystem from dist: The "https://api.github.com/repos/thephpleague/flysystem/zipball/021569195e15f8209b1c4bebb78bd66aa4f08c21" file could not be downloaded: SSL: Connection reset by peer
Failed to enable crypto
failed to open stream: operation failed
    Now trying to download from source

报错4

Command "self-update" is not defined

解决办法:

一、更新composer版本

所以我们要先移除原来的composer:

sudo apt-get remove composer

移除成功后,以composer官方的方式下载composer:

curl -sS https://getcomposer.org/installer | php

并将下载的composer.phar 移动到以下命令指定的目录,使所有用户全局都可以使用composer:

sudo mv composer.phar /usr/bin/composer
chmod +x /usr/bin/composer

完成输入:

composer -v

二、更换源 ,选阿里

安装成最新版本。再次执行就可以了,如果还是报错,就更换源。

国内源的一些连接:Link

我试了试,腾讯的那些不太好,阿里的不错,一路绿灯。

推荐:

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

composer clear-cache

composer create-project --prefer-dist laravel/laravel socket "5.8.*"

取消配置:

composer config -g --unset repos.packagist

 遇到问题?


1. 建议先将Composer版本升级到最新:

composer self-update

2. 执行诊断命令:

composer diagnose

3. 清除缓存:

composer clear

4. 若项目之前已通过其他源安装,则需要更新 composer.lock 文件,执行命令:

composer update --lock

 

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页

打赏作者

追梦赤子心刘大哥

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值