HUD 3336 Count the string(kmp+思维)

Count the string

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12914    Accepted Submission(s): 5948

 

 

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1 4 abab

 

 

Sample Output

 

6

 

 

Author

foreverlin@HNU

 

 

Source

HDOJ Monthly Contest – 2010.03.06

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1711 1686 3341 2222 3068

#include<iostream>
#include<algorithm>
#include<cstring>
#include<stdio.h>
using namespace std;
typedef long long LL;
#define maxn (200005)
#define MOD 10007
int n;
int Next[maxn],cnt;
char seq[maxn];
/*
题意是求每个前缀在原串中的出现次数之和。。。
想法很简单,在求Next数组时如果求出来的Next[i]不为-1,
也就是存在前缀后缀相等,则计数,
(题意貌似没有明确说明其不能重叠)
对于每一个前缀,如果出现过,一定可以通过这种方法找出来并且计数,
至于重复情况,因为i是向前扫的,所以不存在。。。

*/
void getNext(int len)
{
    cnt=0;
    //memset(cnt,0,sizeof(cnt));
    Next[0]=-1;
    int k=-1;
    for(int i=1;i<len;i++)
    {
        while(k>-1&&seq[k+1]!=seq[i])
            k=Next[k];
          //  cout<<seq[k+1]<<" "<<seq[i]<<endl;
        if(seq[k+1]==seq[i]) k++;
        Next[i]=k;
        //cout<<k<<endl;
        if(k>=0) cnt++;
    }
}
int main()
{
    int t;cin>>t;
    while(t--)
    {
        int i;
        scanf("%d",&n);
        for( i=0;i<n;i++) cin>>seq[i];
        seq[i]=0;
        int len=strlen(seq);
        getNext(len);
        printf("%d\n",(cnt+len)%MOD);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值