HDU 1158 Employment Planing (简单dp)

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5955    Accepted Submission(s): 2571


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
 
 
3 4 5 6 10 9 11 0
 

Sample Output
 
 
199
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1227  1074  1080  1024  1025 
 
#include <queue>
#include <iostream>
#include<cstring>
#include<stdio.h>
#define maxn 200050
#define MAX  1e9
using namespace std;
int n;
int hire,salary,fire;
int dp[15][maxn],x;
int seq[maxn],maxv;
int compute(int x)
{
    if(x<0) return (-x*fire);//+x*salary);
    return x*(salary+hire);
}
/*
理清关系即可,
注意解雇人时该月还要发工资
*/
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n&&n)
    {
        maxv=-1;
        cin>>hire>>salary>>fire;
        for(int i=1;i<=n;i++)
        {
            cin>>x;seq[i]=x;
            maxv=max(maxv,x);
        }
        for(int i=seq[1];i<=maxv;i++)  dp[1][i]=i*(salary+hire);
        for(int i=2;i<=n;i++)
        {
            for(int j=seq[i];j<=maxv;j++)
            {
                dp[i][j]=MAX;
                for(int k=seq[i-1];k<=maxv;k++)
                {
                    if(k<=j)   dp[i][j]=min(dp[i][j],dp[i-1][k]+j*salary+(j-k)*hire);
                    else   dp[i][j]=min(dp[i][j],dp[i-1][k]+j*salary+(k-j)*fire);
                }
            }
        }
        int ans=1<<30;
        for(int i=seq[n];i<=maxv;i++)
            ans=min(ans,dp[n][i]);
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值