HDU 6438 Buy and Resell (贪心好题+优先队列)*

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1580    Accepted Submission(s): 548


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i -th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i -th city and choose exactly one of the following three options on the i -th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250 ), indicating the number of test cases. For each test case:
The first line has an integer n . (1≤n≤105 )
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i -th city. (1≤ai≤109 )
It is guaranteed that the sum of all n is no more than 5×105 .

 

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

 

Sample Output

 
16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

 

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

 

 

#pragma comment(linker, "/STACK:102400000,102400000")
#include<bits/stdc++.h>
using namespace std;

#define debug puts("YES");
#define rep(x,y,z) for(int (x)=(y);(x)<(z);(x)++)

#define lrt int l,int r,int rt
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define ll long long

const int  maxn =3e3+5;
const int mod=1e9+7;

#define pii pair<int,int>
#define fi first
#define se second
/*
题目大意:就是一个序列,按顺序走过,
每个节点都有个权重,然后支持三种操作,
买入,卖出,跳过,问最后能得到的最大收益是多少。

对于每个点,无妨是有三种状态,
买入的起点,卖出的终点,中间点(暂态)。
可以肯定刚加入的点在没遇到后面的点之前都是暂态。

买卖链可以用大小关系去延扩,比如1,2,5,1买2卖,2买5卖。
有点像二分图中的增广路径,对于新出现的一对买卖点,
我们要维护出当前的最好的状态并且可以因为后期的变动调整为最优。

对于每个点在最大堆中肯定不止有一个状态。
那么就可以研究下什么情况下一个数两种状态都消去了也对答案无影响。
应该是已经找到继承点的时候,比如1和2,2加入时1的状态全部消失了,
那么2这个点就可以代替1做决策了,如果比2 小那卖的最优,如果出现比其大的,
因为2的状态还没消去,状态还可以扩展下去,就是说2取消了和1的绑定关系,
答案累加的实际上是3-1,(3-2+2-1)2起到桥梁的作用。
*/

int n,x;
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        ll ans=0;int cnt=0;
        priority_queue< pair<int,int> > pq;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            pq.push(make_pair(-x,1));
            pq.push(make_pair(-x,2));
            ll tmp=x+pq.top().fi;
            ans+=tmp;///ans不可能为负数,因为是先加进去后累计答案的,最多就是零。
            if(pq.top().se==1) cnt+=2;
            pq.pop();
        }
        printf("%lld %d\n",ans,cnt);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值