HDU 1856 More is better (并查集基本操作)

93 篇文章 1 订阅
11 篇文章 0 订阅

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2


        
  
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
        
 

题解:

本来是不想写这题的题解的,因为太水了,但是居然tle了几次。。后来发现手抖打错了点东西。。下不为例

代码:

#include<stdio.h>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
#include<map>
using namespace std;
const int MAX=1e7+5;
int pre[MAX];
int mul[MAX];
int find(int x)
{
    if(x!=pre[x])
        pre[x]=find(pre[x]);//注意点,缩小树的深度以节省时间
    return pre[x];
}
int main()
{
    int i,j,n,x,y,d1,d2,maxx,max=MAX-5;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        maxx=1;
        for(i=1;i<=max;i++)
        {
            pre[i]=i;
            mul[i]=1;
        }
        max=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            if(x>y)
                swap(x,y);
            if(y>max)
                max=y;
            d1=find(x);
            d2=find(y);
            if(d1!=d2)
            {
                mul[d1]+=mul[d2];
                pre[d2]=d1;
                if(mul[d1]>maxx)
                    maxx=mul[d1];
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值