HDU 6188 Duizi and Shunzi(贪心)

11 篇文章 0 订阅

Nike likes playing cards and makes a problem of it. 

Now give you n integers,  ai(1in) ai(1≤i≤n) 

We define two identical numbers (eg:  2,2 2,2) a Duizi, 
and three consecutive positive integers (eg:  2,3,4 2,3,4) a Shunzi. 

Now you want to use these integers to form Shunzi and Duizi as many as possible. 

Let s be the total number of the Shunzi and the Duizi you formed. 

Try to calculate  max(s) max(s)

Each number can be used only once. 
Input
The input contains several test cases. 

For each test case, the first line contains one integer n( 1n106 1≤n≤106). 
Then the next line contains n space-separated integers  ai ai ( 1ain 1≤ai≤n
Output
For each test case, output the answer in a line. 
Sample Input
7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
Sample Output
2
4
3
2


        
  
Hint
Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)


题解:

题意:

给你一堆牌,让你求出最大的对子数和顺子数(3个连续的牌)的和

思路:

从右到左扫一遍牌,先把对子打掉,如果还剩下牌,就看下一个数字的牌数是否为奇数,如果是并且下下张牌是有牌的,就连成顺子打出去,这样贪心思路其实是用“废弃"的当前和废弃的下一个奇数牌,使得消耗一个有用的下下张牌就能换成一对,而如果是只打下下张牌的对子那么就是消耗了2张有用的牌(暂时判定)来换来一个对子

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
using namespace std;
#define INF 100861111
#define ll long long
#define eps 1e-7
#define maxn 1e5+5
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
int a[1000005];
int main()
{
    int i,j,n,ans,x;
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        memset(a,0,sizeof(a));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&x);
            a[x]++;
        }
        for(i=1;i<=n;i++)
        {
            ans+=(a[i]/2);
            a[i]%=2;
            if(a[i]&&a[i+1]%2&&a[i+2])
            {
                ans++;
                a[i]--;
                a[i+1]--;
                a[i+2]--;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值