POJ - 3318 Matrix Multiplication(随机化算法)

You are given three n × n matrices AB and C. Does the equation A × B = C hold true?

Input

The first line of input contains a positive integer n (n ≤ 500) followed by the the three matrices AB and respectively. Each matrix's description is a block of n × n integers.

It guarantees that the elements of A and B are less than 100 in absolute value and elements of C are less than 10,000,000 in absolute value.

Output

Output "YES" if the equation holds true, otherwise "NO".

Sample Input
2
1 0
2 3
5 1
0 8
5 1
10 26
Sample Output
YES
Hint
Multiple inputs will be tested. So O(n  3) algorithm will get TLE.
#include<iostream>
#include<ctime>
using namespace std;
const int maxn = 505;
int A[maxn][maxn];
int B[maxn][maxn];
int C[maxn][maxn];
int main()
{
     int N;
     while(cin >> N)
     {
           bool flag=true;

     for (int i = 1; i <=N; i++)
        for (int j = 1; j <=N; j++)
     {
             scanf("%d",&A[i][j]);
     }

     for (int i = 1; i <=N; i++)
        for (int j = 1; j <=N; j++)
     {
             scanf("%d",&B[i][j]);
     }

     for (int i = 1; i <=N; i++)
        for (int j = 1; j <=N; j++)
     {
             scanf("%d",&C[i][j]);
     }

     srand((unsigned)time(NULL));
     for (int i = 0; i< 77777;i++)
     {
             int h = rand()%N + 1,l = rand()%N + 1;
             int temp = 0;
             for (int j = 1;j <=N;j++)
             {
                     temp += A[h][j] * B[j][l] ;
             }
             if(temp != C[h][l])
             {
                     flag = false;
                     break;
             }
     }

     if(flag)
     {
             cout<<"YES"<<endl;
     }
     else{
        cout<<"NO"<<endl;
     }
     }


}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值