PAT 甲级 1010 Bestrank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
结尾无空行
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A
结尾无空行

题目大意

大概。。就是那样

题目分析

我们会发现呢,首先是需要用到排序的。如果要用到排序的话,怎么能少得了STL里的sort()函数呢。。然后排序的过程中呢,ID-data数据对的顺序不能乱,所以要用结构体数组存储信息,因为我们无法在排序过程中就确定每个学生的排名,所以要排完序再那个。。挨个遍历然后更新排名

而且是需要排序4次,因为有四个指标嘛,那传入的compare函数就要灵活一点了。。

最后呢因为我们要通过ID快速查找到那个什么。。data,所以要用到一个map

好好好好复杂啊

AC代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>
using namespace std;
int flag;
struct student {
    string ID;
    int score[4];
    int best_rank;
    int best_sub;
};
unordered_map<string, student> store;
bool compare(student lhs, student rhs) {
    return lhs.score[flag] > rhs.score[flag];
}
int main() {
    student temp;
    vector<student> sut;
    vector<string> check;
    string ID;
    int A, C, M, E;
    int N1, N2; // N1是学生总数,N2是检查排名的学生人数
    cin >> N1 >> N2;
    for (int i = 0; i < N1; i++) {//get data
        cin >> ID >> C >> M >> E;
        temp.ID = ID;
        temp.score[1] = C;
        temp.score[2] = M;
        temp.score[3] = E;
        A = float(C + M + E) / 3.0 + 0.5;//四舍五入
        temp.score[0] = A;
        sut.push_back(temp);
    }
    for (int i = 0; i < N2; i++) {
        cin >> ID;
        check.push_back(ID);
    }

    for (int i = 0; i <= 3; i++) {//排序 0 A 1 C 2 M 3 E//看不起英语是吧?
        flag = i;
        sort(sut.begin(), sut.end(), compare);
        if(flag == 0){
            sut[0].best_rank = 0;
            sut[0].best_sub = 0;
        }
        else{
            if(0<sut[0].best_rank){
                sut[0].best_rank = 0;
                sut[0].best_sub = flag;
            }
        }
        for (int j = 1; j < sut.size(); j++) {
            int temp = j;
            if(sut[j].score[flag] == sut[j-1].score[flag]){
                temp = j - 1;
            }   
            if (flag == 0) {
                sut[j].best_rank = temp;
                sut[j].best_sub = flag;
            }
            else {
                if (temp < sut[j].best_rank) {//省去了优先级比较!
                    sut[j].best_rank = temp;
                    sut[j].best_sub = flag;
                }
            }
        }
    }

    for (auto s : sut) {
        store[s.ID] = s;
    }
    char res[4]{'A', 'C', 'M', 'E'};
    for(auto s: check){
        if(store.count(s)){
            cout << store[s].best_rank + 1 << ' ' << res[store[s].best_sub] << endl;
        }
        else{
            cout << "N/A" << endl;
        }
    }
}     }
        else{
            cout << "N/A" << endl;
        }
    }
    return 0;
}

短短76行代码 搞得我筋疲力尽

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值