分金币(Spreading the Wealth,UVa 11300,中位数)

题目链接

https://vjudge.net/problem/UVA-11300

题目

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone
around a circular table. First, everyone has converted all of their properties to coins of equal value,
such that the total number of coins is divisible by the number of people in the village. Finally, each
person gives a number of coins to the person on his right and a number coins to the person on his left,
such that in the end, everyone has the same number of coins. Given the number of coins of each person,
compute the minimum number of coins that must be transferred using this method so that everyone
has the same number of coins.

Input

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the
village. n lines follow, giving the number of coins of each person in the village, in counterclockwise
order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

题意

圆桌旁坐着n个人,每个人有一定数量的金币a[i],金币总数能被n整除。每个人可以给他左右相邻的人一些金币,最终使得每个人的金币数目相等。你的任务是求出被转手的金币的数量的最小值。

题解

每个人只会与左右相邻的人进行交互,即一共进行n次交互。而A给B两个金币,B给A四个金币等价于B给A两个金币,所以俩人的交互可以用一个值x[i]来表示。问题转化为求n个xi的值之和的最小值。
设x[i]表示第i个人给第i-1个人的金币的数量,如果x[i]为负,说明第i个人从第i-1个那拿了x[i]个金币。
因为最终每个人的金币为所以金币数量的平均值(设为m),所以a[i]-x[i]+x[i+1]=m.
又因为前n-1个人的金币交互完成之后,第
n个人的金币交互就随之确定下来了,所以有效的方程组只有n-1个,也就是说无法根据n-1个方程解n个未知量。
虽然无法解出n个未知量,但是可以统一用一个未知量去表示其他n-1个未知量,即
x[2]=m-a[1]+x[1];
x[3]=m-a[2]+(m-a[1]+x[1])=2m

而除x[1]以外的量都是常量,可以用c[i]来表示。
注意到,c[i]=c[i-1]+a[i]-m.
所以x[i]=|x[1]-c[i]|,即x[i]的几何意义为x[1]与c[i]的距离。求n个xi的值的最小值转化成求一点到数轴上n个点的距离之和的最小值。
上述问题的最优解为:n个点的中位数到n个点的距离之和最小。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
typedef long long ll;
const int maxn=1e6+100;
ll a[maxn],tot,c[maxn];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        tot=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
            tot+=a[i];
        }
        long long m=tot/n;
        c[0]=0;
        for(int i=1;i<=n-1;i++)
            c[i]=c[i-1]+a[i]-m;
        sort(c,c+n-1);
        long long x1=c[(n-1)/2];
        tot=0;
        for(int i=0;i<n;i++)
            tot+=abs(x1-c[i]);
        printf("%lld\n",tot);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值