Problem k-11 Box of Bricks

Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?


Input 

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.


Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.


Sample Input 

6
5 2 4 1 7 5
0


Sample Output 

Set #1
The minimum number of moves is 5.

题目介绍
移动最少数目的砖块将所有的砖盒弄的一般高
解题思路
先累加起所有砖的总数量,再除以砌墙的数量就得到最后的高度,用这个高度减去所有小于它的砖盒的高度,再把所得结果相加,就得出答案
源代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
        vector<int>v;
        int n,b,sum,ave,e,c=0;
        while(cin>>n)
        {
                if(n==0) break;
                c++;
                sum=0;
                e=0;
                v.clear();
                for(int i=0;i<n;i++)
                {
                        cin>>b;
                        v.push_back(b);
                        sum=sum+b;
                }
                ave=sum/n;
                for(int j=0;j<v.size();j++)
                {
                        if(v[j]>ave)
                                e=e+(v[j]-ave);
                }
                        cout<<"Set #"<<c<<endl;
                        cout<<"The minimum number of moves is "<<e<<"."<<endl;
                        cout<<endl;
        }
        return 0;
}

怎么说呢,再简单的题也会有出错的时候,最常见的出错就是Presentation Error

首先可以肯定的是,你的思路没有错,输出结果也与标准输出结果非!常!接!近!出现这个错误最可能的原因是,在输出结果的后面,多了或少了没什么意义的空格,tab,换行符等等。所以,请先认真检查程序的输出结果是否与标准完!全!一!致!OJ平台对格式的检查可以说是非!常!严!格!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值