HDU 4786 Fibonacci Tree

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5502    Accepted Submission(s): 1711


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int N = 200000 + 10;
struct node{
	int u, v, d;
}p[N];
int n, m;
int pre[N], Fib[50];
bool cmp(node a, node b){
	return a.d < b.d;
}
bool cmp1(node a, node b){
	return a.d > b.d;
}
int Find(int x){
	if(x != pre[x]) pre[x] = Find(pre[x]);
	return pre[x];
}
join(int x, int y){
	int t1, t2;
	t1 = Find(x);
	t2 = Find(y);
	if(t1 != t2) pre[t1] = t2;
}
void init(){
	for(int i = 1; i <= n; i++){
		pre[i] = i;
	}
}
int main(){
	Fib[0] = 1, Fib[1] = 1;
	for(int i = 2; i <= 45; i++){
		Fib[i] = Fib[i - 1] + Fib[i - 2];
	}
	int T, iCase = 1;
	scanf("%d", &T);
	while(T--){
		scanf("%d%d", &n ,&m);
		init();
		for(int i = 1; i <= m; i++){
			scanf("%d%d%d", &p[i].u, &p[i].v, &p[i].d);
			join(p[i].u, p[i].v);
		}
		printf("Case #%d: ", iCase++);
		bool flag = true;
		for(int i = 1; i <= n; i++){
			if(Find(1) != Find(i)){
				flag = false;
			}
		}
		if(!flag){
			printf("No\n");
			continue;
		}
		init();
		int cnt = 0, cnt1 = 0, size = 0;
		sort(p + 1, p + 1 + m, cmp);
		for(int i = 1; i <= m; i++){
			if(Find(p[i].u) != Find(p[i].v)){
				cnt += p[i].d;
				join(p[i].u, p[i].v);
				size++;
				if(size == n - 1) break;
			}
		}
		init();
		size = 0;
		sort(p + 1, p + 1 + m, cmp1);
		for(int i = 1; i <= m; i++){
			if(Find(p[i].u) != Find(p[i].v)){
				cnt1 += p[i].d;
				join(p[i].u, p[i].v);
				size++;
				if(size == n - 1) break;
			}
		}
		bool flag1 = true;
		for(int i = 1; i <= 45; i++){
			if(Fib[i] >= cnt && Fib[i] <= cnt1){
				flag1 = false;
				break;
			}
		}
		if(!flag1) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值