1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
#include <iostream>
#include <queue>
using namespace std;

struct node {
	int data;
	node* lchild;
	node* rchild;
};
int n;
int pre[51], post[51], in[51];

node* create(int postL, int postR, int inL, int inR) {
	if (postL > postR) {
		return NULL;
	}
	
	node* root = new node;
	
	root->data = post[postR];
	
	int k = 0;
	for (k = inL; k <= inR; k++) {
		if (post[postR] == in[k]) break;
	}
	
	int numLeft = k - inL;
	root->lchild = create(postL, postL + numLeft - 1, inL, k - 1);
	root->rchild = create(postL + numLeft, postR - 1, k + 1, inR);
	
	return root;
}

void BFS(node* root) {
	queue<node*> q;
	int num = 0;
	q.push(root);
	while (!q.empty()) {
		node* top = q.front();
		q.pop();
		num++;
		printf("%d", top->data);
		if (num < n) printf(" ");
		
		if (top->lchild != NULL) q.push(top->lchild);
		if (top->rchild != NULL) q.push(top->rchild);
	}
}

int main() {

	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d" , &post[i]);
	}
	for (int i = 0; i < n; i++) {
		scanf("%d", &in[i]);
	}
	
	node* root = create(0, n - 1, 0, n - 1);
	BFS(root);

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值