HDOJ2123 An easy problem

An easy problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8539    Accepted Submission(s): 5870


Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the i th row and j th column should be the product(乘积) of i and j.
 

Input
The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
 

Output
For each test case, print out the multiply table.
 

Sample Input
  
  
2 1 4
 

Sample Output
  
  
1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16
Hint
There is no blank space at the end of each line.
 
输出一个乘法表的结果,每一个数中间有一个空格。
使用for循环直接输出就是了。

import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		int n = scanner.nextInt();
		while(n-->0){
			int line = scanner.nextInt();
			for (int i = 1; i <= line; i++) {
				for (int j = 1; j <= line; j++) {
					if(j == 1){
						System.out.print(i*j);
					}else {
						System.out.print(" "+i*j);
					}
				}
				System.out.println();
			}
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值