[PAT B1019/A1069]数字黑洞

[PAT B1019/A1069]数字黑洞

本题是PAT乙级1019题和甲级1069题,这里先放英文原题,要做乙级的朋友们可以直接跳过看后面的中文原题

题目描述

1069 The Black Hole of Numbers (20 分)For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.
For example, start from 6767, we’ll get:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

输入格式

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

输出格式

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

输入样例1

6767

输出样例1

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例2

2222

输出样例2

2222 - 2222 = 0000

--------------------------中文原题---------------------------

题目描述

1019 数字黑洞 (20 分)给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式

输入给出一个 (0,10​4​​) 区间内的正整数 N。

输出格式

如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

解析

  1. 这道题目不难,重点是如果解题人对于一些工具函数很熟悉的话,那么这个题目就会非常简单,需要注意的就是,输入的数在0~10000之间,有可能是不是四位数,那么对于三位数也要注意格式。
  2. 下面是原代码:
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
bool cmp(char a,char b) {
 return a > b;
}
int main() 
{
 string ans;
 cin >> ans;
 ans.insert(0, 4 - ans.length(), '0');//insert函数,表示在0位置插入长度为4-ans.length()的‘0’
 do {
  string s1, s2;
  s1 = ans, s2 = ans;
  sort(s1.begin(), s1.end());
  sort(s2.begin(), s2.end(), cmp); //要善用排序函数,这里不使用排序函数会十分麻烦
  ans = to_string(stoi(s2) - stoi(s1));
  ans.insert(0, 4 - ans.length(), '0');
  cout << s2 << " - " << s1 << " = " << ans << endl;
 } while (ans!="6174" && ans!="0000");
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值