求最大公约数算法

1.辗转相除法

int gcd(int m,int n) {
int t;
while (n > 0)
{
t = m%n;
m = n;
n = t;
}
return m;
}

2.

c=min(a,b)

for(int i=c;i>0;i--)    {  
      if((a%i==0&&b%i==0))        

       k=i; //k为最大公约数
   }

3.更相减损法

第一步:任意给定两个正整数;判断它们是否都是偶数.若是,则用2约简;若不是则执行第二步.
第二步:以较大的数减较小的数,接着把所得的差与较小的数比较,并以大数减小数.继续这个操作,直到所得的减数和差相等为止,则这个等数就是所求的最大公约数.
其中所说的“等数”,就是最大公约数.求“等数”的办法是“更相减损”法,实际上就是辗转相除法. 
例 用更相减损术求98与63的最大公约数
由于63不是偶数,把98和63以大数减小数,并展转相减
98-63=35
63-35=28
35-28=7
28-7=14
14-7=7
所以,98和63的最大公约数等于7.

r然后就贴一道hdoj水题

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator. 

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 

Sample Input
  
  
3 5 15 20 63923 99999
 

Sample Output
  
  
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
#include<stdio.h>
using namespace std;
int main() {
int a, b;
int gcd(int m, int n);
while (cin >> a >> b&&b)
{
if (gcd(a, b) != 1)
printf("%10d%10d    Bad Choice\n\n", a, b);
else
printf("%10d%10d    Good Choice\n\n", a, b);
}
}
int gcd(int m,int n) {
int t;
while (n > 0)
{
t = m%n;
m = n;
n = t;
}
return m;
}


最后最小公倍数等于两数之和除以最大公约数

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值