cocos2dx打包Android出现“未指定Android目标平台版本”问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_38306233/article/details/78849792

cocos编译Android包时出现问题:

使用Eclipse工程:G:\cocosstudio\Popapple\proj.android 未指定Android目标平台版本,自动查找一个可用版本。。。。。。

未找到工程‘G:\cocosstudio\Popapple\proj.android ’可用的Android目标平台,Android目标平台版本应该大于或等于19.


网上看别人的解决方法

把环境变量中的ANT_ROOT、NDK_ROOT和ANDROID_SDK_ROOT变量清掉,然后点击cocos2dx安装文件下的setup.py重新设置一下,用于清除已经被错误设置的环境变量,然后再自己手动设定以上变量即可解决。


我个人试过网上搜的方法,并没能解决我自己的这个问题,最后我的解决办法是

找到SDKManager.exe运行进行更新,看缺哪个API,就更新哪个(这个更新会比较慢,原因国内Google被禁),例如:Android目标平台应大于等于19,那就安装API19以上的SDK。


不知道别人用能不能成功,但是本菜鸡成功了。如果有什么问题或更好的解决办法可以私信交流。


展开阅读全文

没有更多推荐了,返回首页