Doris安装步骤及常见错误总结

1.准备阶段

1.1 需要的软件包

**
doris_v4.06beta2.tar.gz
fftw-3.2.1.tar.gz
getorb_2.3.2.tar.gz
snaphu-v1.4.2.tar.gz
**

Doris解压后文件夹内的内容
在这里插入图片描述
添加文件到解压文件夹之后
在这里插入图片描述
图中的ENVISAT_TOOLS和SARtools是doris_v406beta2解压后自带的,不需要单独下载。

1.2安装软件包和相关依赖

 1)、安装新立得:
    $sudo apt-get install synaptic
 2)、安装gawk gcc g++ make tcsh csh gmt 
   (注意:4.1或4.2版本的gcc在安装Envisat_tool 时不会报错,如果安装了高版本的gcc可参考https://blog.csdn.net/qq_38372838/article/details/99699705安装低版本gcc)
    $sudo apt-get install gawk gcc g++ make tcsh csh gmt
 3)、 安装terrasar-x影像包:
    $sudo apt-get install gdal-bin libxslt1.1 python-lxml python libxml2
 4)、安装Cosmo-SkyMed影像包:
    $sudo apt-get install python-h5py
注:新立得下载的安装包文件存放在:/var/cache/apt/archives/ 目录下

1.2.1 为了防止相关网页无法访问造成困扰,我直接附上安装gcc4.1.2详细步骤(如果gcc版本为4.1或4.2请忽略此步):

1.2.1.1 创建文件夹并下载gcc压缩包

mkdir /tmp/gcc
cd /tmp/gcc
wget http://ftp.gnu.org/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2
tar -xvjpf ./gcc-4.1.2.tar.bz2
mkdir ./build

1.2.1.2 安装相关依赖

sudo apt-get install linux-headers-$(uname -r) zlib1g zlib1g-dev zlibc gcc-multilib

1.2.1.3
你可能安装有其他版本的ld,这个版本的ld可能不是gcc4.1.2安装时所需要的,因此需要改动./gcc-4.1.2/libstdc+±v3/configure文件的第8284行, 将

sed -e 's/GNU ld version \([0-9.][0-9.]*\).*/\1/'`

改为

sed -e 's/GNU ld (GNU Binutils for Ubuntu) \([0-9.][0-9.]*\).*/\1/'`

并且创建如下链接

sudo ln -s /usr/lib/x86_64-linux-gnu/crt1.o /usr/lib/crt1.o
sudo ln -s /usr/lib/x86_64-linux-gnu/crti.o /usr/lib/crti.o
sudo ln -s /usr/lib/x86_64-linux-gnu/crtn.o /usr/lib/crtn.o

1.2.1.4
将工作路径改为第一步中创建的build文件夹下,并且执行

../gcc-4.1.2/configure --program-suffix=-4.1 --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --disable-libunwind-exceptions --enable-__cxa_atexit --enable-languages=c,c++ --disable-multilib
sudo apt-get install texinfo

修改./Makefile,将

CC = gcc
CXX = g++

改为

CC = gcc -fgnu89-inline
CXX = g++ -fgnu89-inline

1.2.1.5
如果没有遇到问题,则执行make和sudo make install(一般不会出现问题,如果有问题请检查手动输入的过程中的输入错误,比如1.2.1.3中连接里的crt1.o是1不是l)

make -j 2 bootstrap MAKEINFO=makeinfo
sudo make install

如果安装成功,则会将gcc-4.1.2添加到$PATH中
1.2.1.6
更新$PINTOSSRC/pintos/src to use gcc-4.1中的Make.config(此步可以忽略)

2 安装doris4.06beta2

2.1编译安装fftw-3.2.1

$ cd fftw-3.3.3/
$ ./configure --prefix=`pwd` --enable-float
注: 如果出现"./configure  Permission Denied", 输入命令sudo chmod +x configure给configure赋权限。再执行./configure --prefix=`pwd` --enable-float然后回车
若按装过程出错的话,需要将安装包删除,全部重新安装
注意,--prefix=`pwd`中的斜撇是键盘上数字1边上的斜撇。
【这一步configure选项可以进一步优化。我们现在的机器都支持sse,cpu都是多核心的,可以加  上--enable-sse 和 --with-combined-threads选项,也就是下面的命令:$./configure --prefix=`pwd` --enable-float --enable-sse --with-combined-threads
 //特别的,如果是32位linux系统,用的是amd的cpu,可以加上 --enable-k7】
$ make
$ make install

编译安装,注意--prefix=`pwd`选项保证了fftw库直接安装在pwd,也就是当前的 fftw-3.3.3目录,doris编译时会直接找到自己目录下的fftw。

2.2 编译安装doris

$ cd src
//进入到doris下面的src目录
$ ./configure
$ make
$ sudo make install
//最后一步安装doris到/usr/local/bin需要root权限
注:1. 在./configure时如果报错 no such file or directory, 可以输入sudo apt-get install csh 安装时会询问一些问题,请参考这篇文章https://blog.csdn.net/ivan_ljf/article/details/11030115
2.由于fftw在安装时安装到了当前fftw3.2.1目录,在compile时会检测到fftw的安装路径等,因此在出现===> What is your C++ complier? 等问题时,按照中括号内的提示填写即可

2.3 编译安装ENVISAR_TOOLS

$ cd doris_v4.02/ENVISAT_TOOLS 
$ make
$ sudo make install
注:如果出现 Makefiles:53:recipe for target 'envisat_dump_header' faild 错误时,请参考https://blog.csdn.net/qq_38372838/article/details/99699705,失败原因为gcc版本过高,如何安装低版本gcc已在1.2.1中详细介绍了。

2.4编译安装SARtools

$ cd doris_v4.04beta4/SARtools
$ make
$ sudo make install
若是64位Ubuntu,ENVISAT_TOOLS 需要先安装 libc-dev-i386
$ sudo apt-get install  libc6-dev-i386
$ make
$ sudo make install

2.5安装getorb

snaphu与getorb软件都放到doris目录下
 A.先安装fortran包
    $ sudo apt-get install gfortran
    注意:修改getorb安装文件目录下Makefile文件,第34行和38行,去掉行首的注释符号“#” 
    FC    =fc
    FC    =gfortran

 B.再安装getorb
    进入getorb目录
    $ make
    $sudo make install
   可使用getorb检查安装是否成功
 注意:拷入精轨文件的时候必须注意大小写,即轨道文件必须大写的,doris才能正确读入精轨

2.6编译安装snaphu

首先到“/usr/local”文件夹下建个 man文件夹,在man文件夹下建立man1文件夹,再进入  snaphu/src下make、make install,最后make install如果提示还有一个错误,不用管

$ sudo mkdir /usr/local/man/man1  //若是fedora要分步创建
 进入snaphu/src目录,make 和 sudo make install。

2.7赋予执行权限

 以上软件的执行文件都安装在 /usr/local/bin下面,到该目录里面去检查一下,发现有几个文件没有执行权限,增加执行权限即可。
$ cd /usr/local/bin
$ sudo chmod 755 *.*
$ sudo chmod 755 *
 在终端运行run -g时提示添加PAGER,EDITOR到环境变量。编辑/home/Administrator(用户名,例如root)目录下.bashrc文件(为隐藏文件,Ubuntu下Ctrl+H显示),在最后加入下面两行代码:
export PAGER=less
export EDITOR=vi

本文大部分内容来源于https://blog.csdn.net/ivan_ljf/article/details/52267933,在此基础上,增加了自己在安装过程中遇到的一些问题及解决方法,希望能够帮助到大家。

  • 1
    点赞
  • 0
    评论
  • 9
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值