多个版本JDK 环境配置问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_38380025/article/details/80433589

jdk安装,下一步下一步,选择安装盘,安装即可,jre可以安装到jdk的jre里进行覆盖,也可以单独安装,

创建

CLASSPATH

.\;%JAVA_HOME%\lib\td.jar;%JAVA_HOME%\lib\tools.jar;

创建jdk home

JAVA_HOME

选择你自己的home

C:\Java\java6

 

在path里进行添加

天遇到的问题,本来特别简单的事情,就是切换一下jdk,我电脑原来装jdk1.7的,不料进了新公司后,需要用jdk1.6,得必须切换了,我把环境变量 java_home,切换后,在cmd里输入 java -version 居然还显示的是1.7,然后就跟着path里的路径一个一个的找,一个一个的测试,最后还是不行,最后把用户的环境变量里的path删除了,cmd里依然显示1.7,然后又把系统变量里的path删除了,果然什么也不显示了,但是也没有了环境变量不能开发呀?这样不行,接着又把系统里的path加上,写上最初的值,但是cmd里依然显示着 1.7,我就纳闷了,我两个path里都没配置java_home为什么还显示的是1.7版本的jdk,这会儿彻底晕了,然后各种百度,最后终于找到了,在系统里的 C:\Windows\System32 这个文件夹里居然有c:/windows/system32/java.exe 

c:/windows/system32/javaw.exe 

c:/windows/system32/javaws.exe 

如果你安装的是64位的,这三个文件在

C:\Windows\SysWOW64 下面

这三个文件,java的jdk什么时候这么坑了,在sytem32里自己给加上了,害的我找了半天,然后把这三个文件删除后,按照原来的方式配置环境变量,然后再在cmd里显示,果然显示正确了,没问题了,以此写出来给大家共享,以免大家走弯路。

注意删除后必须冲洗打开cmd进行输入java -version 要不是不生效的,如果还是最高的版本继续下一步

找到你的系统变量的path 变量, 最前面的那段

C:\Program Files (x86)\Common Files\Oracle\Java\javapath

在文件夹中找到这个文件夹

这三个文件 也是需要删除的(如果有的话) 即可

最后的

在更改jdk 的时候,启动idea 有时会出现这种错误

个人认为是运行时环境跟jdk 版本不通所导致的问题 关闭idea 重新启动即可

 

 

 

展开阅读全文

没有更多推荐了,返回首页