模板--二叉树

给定一棵二叉树的前序和中序遍历序列,求其后序遍历序列。题目提供了一棵包含n个节点的二叉树,并给出两个序列。通过二叉树的构建原理,可以利用这两个序列找出后序遍历序列。
摘要由CSDN通过智能技术生成

问题描述:

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.


输入:

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

输出:

For each test case print a single line specifying the corresponding postorder sequence.

样例输入:

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

样例输出:

7 4 2 8 9 5 6 3 1

思路:

大致题意,已知前序和中序,求后序。根据二叉树的构建思想即可。

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;   int t;
struct treenote
{
    int elem;
    treenote *lchild;
    treenote *rchild;
};
treenote *gettree(int  *preorder,int  *inorder ,int len)
{
    if(len<=0)
        return NULL;
    treenote *note =new treenote;
    note ->elem =*preorder;
int     root=0;
   while(root<len)
   {
       if(*preorder==inorder[root])
        break;
       root++;
   }
    note->lchild=gettree(preorder+1,inorder,root);
    note->rchild=gettree(preorder+1+root,inorder+root+1,len-root-1);
   len==t? cout<<note->elem :cout<<note->elem<<" ";
    return note;

}
int main()
{

    int preorder[1020],inorder[1020];
    while (cin>>t&&(1<=t<=1000))

   {
       for(int i=0;i<t;i++)
        cin>>preorder[i];
       for(int i=0;i<t;i++)
        cin>>inorder[i];
    gettree(preorder, inorder, t);
    cout<<endl;
   }
    return 0;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值