pta--1029 Median(25 分)(思维&&解决内存超限)*

1029 Median(25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

【分析】题意挺好理解的吧,就是输出两个序列合并后的中位数。注意两个序列都是有序的。一开始直接用sort了,但是最后一个测试点说内存超限。然后把int都改成了long long,,,,然后,最后4个点都是内存超限。好吧,方法问题了~

思路及代码参考大神:柳婼 の blog   https://www.liuchuo.net/archives/2248

分析:开一个数组,在线处理第二个数组。 第一二个数组(下标从1开始)分别有n,m个元素,中间数在(n + m + 1) / 2的位置。所以只要从小到大数到(n + m + 1) / 2的位置就行了~ count计总个数 ,给第一个数组设置指针i,每次从第二个数组中读入temp,检查第一个数组中前几个数是不是比temp小,小就count+1并判断是否到数了中间数,到了就输出。 如果数完比temp小的数还没到中间数,count+1,检查temp是不是中间数,是就输出。循环上述过程。如果第二个数组读取完了,还没数到中间数,说明中间数在剩下的第一个数组中,就在剩下的数组中数到中间数位置即可

【代码】

#include<iostream>
#include<cstdio>
using namespace std;
int k[200005];
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&k[i]);
	int m;
	scanf("%d",&m);
	int temp,cnt=0,i=1;
	k[n+1]=0x7fffffff;//long int的最大值
	int midpos=(n+m+1)/2;
	for(int j=1;j<=m;j++)
	{
		scanf("%d",&temp);
		while(k[i]<temp)
		{
			cnt++;
			if(cnt==midpos)cout<<k[i];
			i++;
		}
		cnt++;
		if(cnt==midpos)cout<<temp;
	}
	while(i<=n)
	{
		cnt++;
		if(cnt==midpos)cout<<k[i];
		i++;
	}
	return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值