【HDU-1702】 ACboy needs your help again!


点击打开链接


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8528    Accepted Submission(s): 4272


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
  
  
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
  
  
1 2 2 1 1 2 None 2 3

//栈与队列的问题  

//栈是先进后出,队列是先进先出。  

// 头文件   #includde <stack>   //#include <queue>   // using namespace std;

//栈和队列的操作 

//代码如下:

#include <stdio.h>
#include <stack>        //栈   
#include <queue>        //队列 
#include <string.h>
using namespace std;
int main()
{
	int n,i,j,m,t,r,k;
	char a[7],b[7];
	char str1[] = "FIFO";
	char str2[] = "FILO";
	char str3[] = "IN";
	char str4[] = "OUT";
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%s",&m,&a);
//		scanf("%s",&a);
		t = strcmp(a,str1);
		r = strcmp(a,str2);
		if(r==0)
		 {
		 	stack<int >   p;
		 	for(i=0;i<m;i++)
		 	 {
		 	 	 scanf("%s",&b);
		 	 	 if(strcmp(b,str3)==0)
		 	 	 {
		 	 	 	scanf("%d",&k);
		 	 	 	p.push(k);         //在 栈顶压入新元素 
				 }
				 if(strcmp(b,str4)==0)
				 {
				 	if(p.empty())       // 如果栈为空返回true 否则返回false 
				 	  printf("None\n");
				 	else
				 	  {
				 	  	printf("%d\n",p.top());   //返回栈顶元素但不删除此元素 
				 	  	p.pop();                  //删除栈顶元素但不返回其值 
					   }
				 }
			  }
		 }
		if(t==0)
		 {
			queue<int >   q;           //q.back()   返回队尾元素的值但不删除
			                           //q.size()    返回队列中元素的个数
									   //p.size()      返回栈中元素的个数
			for(i=0;i<m;i++)
		 	 {
		 	 	 scanf("%s",&b);
		 	 	 if(strcmp(b,str3)==0)
		 	 	 {
		 	 	 	scanf("%d",&k);
		 	 	 	q.push(k);       //在队尾压入新的元素 
				 }
				 if(strcmp(b,str4)==0)
				 {
				 	if(q.empty())
				 	  printf("None\n");
				 	else
				 	  {
				 	  	printf("%d\n",q.front());    //返回队列元素的首元素的值 但不删除 
				 	    q.pop();                    //删除 
					   }
				 	
				 }
			  }
		 }
	}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值