数据结构-02-线性结构2 一元多项式的乘法与加法运算 (20 分)

02-线性结构2 一元多项式的乘法与加法运算 (20 分)

设计函数分别求两个一元多项式的乘积与和。

输入格式:

输入分2行,每行分别先给出多项式非零项的个数,再以指数递降方式输入一个多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:

输出分2行,分别以指数递降方式输出乘积多项式以及和多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。零多项式应输出0 0。

输入样例:

4 3 4 -5 2 6 1 -2 0
3 5 20 -7 4 3 1

输出样例:

15 24 -25 22 30 21 -10 20 -21 8 35 6 -33 5 14 4 -15 3 18 2 -6 1
5 20 -4 4 -5 2 9 1 -2 0

分析

1.是不是pat改版改的哇, 两到题都有些问题过不了,测试点3输入有零多项式和常数多项式不管是输出还是不输出系数为零的多项式,都有错误。

代码

#include<stdio.h>
#include<stdlib.h>
 
typedef struct PolyNode *Polynomial;
int length = 0;
struct PolyNode {
  int coef;
  int expon;
  Polynomial link;
};

void Attach(int c, int e, Polynomial* pRear)
{
  Polynomial P;
  P = (Polynomial)malloc(sizeof(struct PolyNode));
  P->coef = c;
  P->expon = e;
  P->link = NULL;
  (*pRear)->link = P;
  *pRear = P;
}

Polynomial ReadPoly (void)
{
  Polynomial P,Rear,t;
  int n;
  int c;
  int e;
  scanf("%d", &n);
  P = (Polynomial)malloc(sizeof(struct PolyNode));
  P->link = NULL;
  Rear = P;
  while(n--)
  {
    scanf("%d %d", &c, &e);
    Attach(c, e, &Rear);
  }
  t = P;
  P = P->link;
  free(t);
  return P;
}

Polynomial Mult(Polynomial P1, Polynomial P2)
{
  Polynomial t1,t2,P,Rear,t;
  int e;
  int c;
  if(!P1||!P2) return NULL;
  t1 = P1;
  t2 = P2;
  P = (Polynomial)malloc(sizeof(struct PolyNode));
  P->link = NULL;
	Rear=P;
  while(t2)
  {
    Attach(t1->coef*t2->coef,t1->expon+t2->expon,&Rear);
    t2 = t2->link;
    length++;
  }
  t1 = t1->link;
  while(t1)
  {
    Rear = P;
    t2 = P2;
    while(t2)
    {
      c = t1->coef*t2->coef;
      e = t1->expon+t2->expon;
      while(Rear->link&&Rear->link->expon>e) Rear=Rear->link;
      if(Rear->link &&Rear->link->expon==e)//Rear->link╢Макр╩мМио
      {
        if(Rear->link->coef+c) Rear->link->coef+=c;
        else{
          t = Rear->link;
          Rear->link = t->link;
          free(t);
          length--;
        }
      }
      else{
        t = (Polynomial)malloc(sizeof(struct PolyNode));
        t->coef = c;
        t->expon=e;
        t->link = Rear->link;
        Rear->link =t;
        Rear = Rear->link;//?
        length++;
      }
      t2 = t2->link;
    }
    t1 = t1->link;
  }
  t = P;
  P = P->link;
  free(t);
  return P;

}

void Print(Polynomial P)
{
  int flag = 0;
  int cnt = 0;
  if (!P) {printf("0 0\n"); return;}
  while(P)
  {
	if(!flag) flag = 1;
	else{
		printf(" ");
	}
	printf("%d %d", P->coef ,P->expon );
	cnt ++;
	P = P->link;
  }
	printf("\n");
}
Polynomial Add(Polynomial P1, Polynomial P2) {
  Polynomial t1,t2,P,Rear,t;
  int e;
  int c;
  if(!P1||!P2) return NULL;
  t1 = P1;
  t2 = P2;
  
  P=(Polynomial)malloc(sizeof(struct PolyNode));
  Rear = P;
  while(t1 && t2) {
    if(t1 -> expon == t2 -> expon){
      if(t1 -> coef != -(t2 -> coef)) Attach(t1 -> coef + t2 -> coef, t1 -> expon, &Rear);
      t1 = t1 -> link;
      t2 = t2 -> link;
    }
    else if(t1 -> expon > t2 -> expon){
      Attach(t1 -> coef, t1 -> expon, &Rear);
      t1 = t1 -> link;
    }
    else {
      Attach(t2 -> coef, t2 -> expon, &Rear);
      t2 = t2 -> link;
    }
  }
  Rear -> link = t1 ? t1 : t2;
  t = P;
  P = P->link;
  free(t);
  return P;
}

int main()
{
  Polynomial P1,P2,Pmulti, Pplus;
  P1=ReadPoly();
  P2=ReadPoly();

  Pmulti=Mult(P1,P2);
  Pplus = Add(P1,P2);

  Print(Pmulti);
  Print(Pplus);

  return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值