1123 Is It a Complete AVL Tree(AVL树)

标明出处:https://www.liuchuo.net/archives/2732

1123 Is It a Complete AVL Tree(30 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
这里写图片描述这里写图片描述
这里写图片描述这里写图片描述
Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print “YES” if the tree is complete, or “NO” if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

分析:这道题实际上考察AVL树和层序遍历两个知识点~~
判断是不是完全二叉树,就看在出现了一个孩子为空的结点之后是否还会出现孩子结点不为空的结点,如果出现了就不是完全二叉树。
AVL树一共有四种情况,这里我把发现树不平衡的那个结点叫做A结点,A发现树不平衡的情况有四种:
新来的结点插入到A的左子树的左子树
新来的结点插入到A的左子树的右子树
新来的结点插入到A的右子树的左子树
新来的结点插入到A的右子树的右子树
发现不平衡时就需要处理,第1种情况只要简单的右旋,第4种情况只需左旋一下,第2种情况需要先对A的左子树左旋一下,然后对A右旋,同理第3种情况需要对A的右子树右旋一下,然后对A左旋就可以啦~~~

#include <iostream>
#include <queue>
#include <cstdio>
using namespace std;

struct node {
    int val;
    node *l, *r;
};
int getHeight(node *tree);
node * leftRotate(node *tree) {
    node *tmp = tree->r;
    tree->r = tmp->l;
    tmp->l = tree;
    return tmp;
}
node * rightRotate(node *tree) {
    node *tmp = tree->l;
    tree->l = tmp->r;
    tmp->r = tree;
    return tmp;
}
node * leftRightRotate(node *tree){
    tree->l = leftRotate(tree->l);
    return rightRotate(tree);
}
node * rightLeftRotate(node *tree) {
    tree->r = rightRotate(tree->r);
    return leftRotate(tree);
}
node *insert(node *tree, int val){
    if(tree == NULL) {
        tree = new node();
        tree->val = val;
    }else if(tree->val > val) {
        tree->l = insert(tree->l, val);
        int l = getHeight(tree->l);
        int r = getHeight(tree->r);
        if (l - r >= 2) {
            if(val < tree->l->val)
                tree = rightRotate(tree);
            else
                tree = leftRightRotate(tree);
        }
    }else{
        tree->r =insert(tree->r, val);
        int l = getHeight(tree->l);
        int r = getHeight(tree->r);
        if(r - l >= 2) {
            if (val > tree->r->val)
                tree = leftRotate(tree);
            else
                tree = rightLeftRotate(tree);
        }
    }
    return tree;
}
int getHeight(node *tree) {
    if(tree == NULL) return 0;
    int l = getHeight(tree->l);
    int r = getHeight(tree->r);
    return max(l,r) + 1;
}
int isComplete = 1, after = 0;
vector<int> levelOrder(node *tree) {
    vector<int> v;
    queue<node *> q;
    q.push(tree);
    while(!q.empty()){
        node *tmp = q.front();
        q.pop();
        v.push_back(tmp->val);
        if(tmp->l != NULL) {
            if (after) isComplete = 0;
            q.push(tmp->l);
        }else{
            after = 1;
        }
        if(tmp->r != NULL) {
            if (after) isComplete = 0;
            q.push(tmp->r);
        } else{
            after = 1;
        }
    }
    return v;
}
int main() {
    int n, tmp;
    scanf("%d", &n);
    node *tree = NULL;
    for(int i = 0; i < n; i++) {
        scanf("%d", &tmp);
        tree = insert(tree, tmp);
    }
    vector<int> v = levelOrder(tree);
    for (int i = 0; i < v.size(); i++) {
        if (i != 0) printf(" ");
        printf("%d", v[i]);
    }
    printf("\n%s", isComplete ? "TES" : "NO");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值