Uva 514 Rails (STL 栈+队列 模拟)

There is a famous railway station in PopPush City. Country there is incredibly hilly. The stationwas built in last century. Unfortunately, funds were extremely limited that time. It was possible toestablish only a surface track.
这里写图片描述
Moreover, it turned out that the station could be only a dead-end one
(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction
B with coaches reorganized in some way. Assume that the train arriving from the direction A has
N

1000
coaches numbered in increasing order1;2;:::;N. The chief for train reorganizations must
know whether it is possible to marshal coaches continuing in the direction B so that their order will
bea1:a2;:::;aN. Help him and write a program that decides whether it is possible to get the required
order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station.
But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.
Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer
N
described
above. In each of the next lines of the block there is a permutation of
1
;
2
;:::;N
. The last line of the
block contains just ‘
0
’.
The last block consists of just one line containing ‘
0
’.
Output
The output file contains the lines corresponding to the lines with permutations in the input file. A line
of the output file contains ‘
Yes
’ if it is possible to marshal the coaches in the order required on the
corresponding line of the input file. Otherwise it contains ‘
No
’. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding
to the last “null” block of the input file.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No
Yes

题目大意:A站有编号为1到n的火车依次排列,驶入C站后驶出,给入驶出顺序,判断该顺序是否合理。直观思路,假想A站为一个队列q,火车只能按序从队首出队,C站为一个栈s,从A站驶入为压栈操作,驶出为出栈操作,定义两个实时变量,记录队首元素和栈顶元素,进行逻辑判断。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;

queue<int> q;
stack<int> s;

int main(){
    int n,c0,c,f;
    int a,b;
    while(scanf("%d",&n),n){
        while(!q.empty()) q.pop();
        while(!s.empty()) s.pop();


        while(scanf("%d",&c0),c0){
            a=0; b=0;
            int flag=1;
            while(!q.empty()) q.pop();
            while(!s.empty()) s.pop();
            for(int i=1;i<=n+1;i++) q.push(i);
            for(int i=1;i<=c0;i++){
                f=q.front();q.pop();
                s.push(f);
            }
            s.pop();
           if(!s.empty()) a=s.top();
           if(!q.empty()) b=q.front();
            for(int i=2;i<=n;i++){
                scanf("%d",&c);
                if(c==a){ s.pop(); //若C站内有该编号的火车,且为栈顶
                    if(!s.empty())
                    a=s.top();

                }
                else if(c>=b){     //若A站内有该编号的火车
                        for(int j=b;j<=c;j++){
                            f=q.front();q.pop(); //将b~c的火车从A站中取出,压入C中
                            s.push(f);
                        }
                    s.pop();
                    if(!s.empty()) a=s.top();
                    if(!q .empty()) b=q.front();

                    }
                else {flag=0;}
        }
        printf("%s\n",flag?"Yes":"No");
    }
        printf("\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值