PAT A 1022 Digital Library (30分)

PAT A 1022 Digital Library (30分)

吐槽:

这题简直就是全明星阵容。豪华的6个include。事真多啊。
不过逻辑倒没什么特别复杂的。毕竟就是做个了小数据库的搜索嘛,基本都是有现成STL代码可以实现的。

思路

本来我打算像往常一样用我惯用的结构体存每一本书的信息的……然后看到了题目里标签不超过1000个的保证和没有按ID输出的输出要求,瞬间明白了点什么,掏出了multimap。
代码逻辑是用每个项的值作为key,ID作为值存进相应的multimap中:
如ID=1111111 title="The Testing Book"的这项是被存成了
multimap<string, int> title;
title.insert(pair<string,int>(The Testing Book,1111111));
这样的好处是之后调用非——常的方便。
不过说实话,现在想来,相比multimap,也许map<string,set< int>>更好?毕竟后面的输出要排序。

然后就是处理奇怪的带空格读入方式的CWS()和最后输出时用来排序的set了。

测试坑点

  • 输出的ID要求是7位的,用int保存然后直接输出的话,前面的0(如果有)不会输出。这个问题会导致最后两个测点出错。
  • 输出的ID是要按大小顺序输出的。set解决之即可。

原题

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
​4
​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year
Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

代码

#include<iostream>
#include<vector>
#include<string>
#include<map>
#include<set>
#include<iomanip>

using namespace std;

string CWS();//cin with space

int main()
{
	int n;
	cin >> n;
	multimap<string, int> title;
	multimap<string, int> author;
	multimap<string, int> keyword;
	multimap<string, int> publisher;
	multimap<string, int> year;
	int tempi, tempii;
	string temps;
	char tempc;
	for (int i = 0; i < n; i++)
	{
		cin >> tempi;
		cin >> noskipws >> tempc;
		temps = CWS();
		title.insert(pair<string,int>(temps, tempi));
		temps = CWS();
		author.insert(pair<string, int>(temps, tempi));
		do
		{
			cin >> noskipws >> temps >> tempc;
			keyword.insert(pair<string, int>(temps, tempi));
		} while (tempc != '\n');
		temps = CWS();
		publisher.insert(pair<string, int>(temps, tempi));

		cin >> temps >> tempc;

		year.insert(pair<string, int>(temps, tempi));
	}

	int m;
	cin >> m >> tempc;
	multimap<string, int>* mapp = NULL;
	multimap<string, int>::iterator it;
	int count;
	pair<int, string>* needs;
	needs = new pair<int, string>[m];
	set<int> output;
	set<int>::iterator it2;
	for (int i = 0; i < m; i++)
	{
		cin >> tempi >> tempc >> tempc;

		temps= CWS();
		needs[i].first = tempi;
		needs[i].second = temps;
	}
	for (int i = 0; i < m; i++)
	{
		cout << needs[i].first << ": " << needs[i].second << endl;
		switch (needs[i].first)
		{
		case 1:
			mapp = &title;
			break;
		case 2:
			mapp = &author;
			break;
		case 3:
			mapp = &keyword;
			break;
		case 4:
			mapp = &publisher;
			break;
		case 5:
			mapp = &year;
			break;
		}

		it = mapp->find(needs[i].second);
		count = mapp->count(needs[i].second);
		if (it == end(*mapp))
		{
			cout << "Not Found" << endl;
		}
		else
		{
			output.clear();
			for (; count > 0; it++, count--)
			{
				output.insert(it->second);
			}
			for (it2 = output.begin(),tempi=0; tempi<output.size(); it2++,tempi++)
			{
				cout << setw(7) << setfill('0') << *it2 << endl;
			}
		}
	}
}

string CWS()
{
	string s0, st;
	char c;
	cin >> noskipws >> st >> c;

	s0 = "";
	while (c == ' ')
	{
		s0 += st;
		s0 += c;
		cin >> noskipws >> st >> c;
	}
	s0 += st;
	return s0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值