并差集水题

发现自己好菜啊,看来每天刷OJ不能停,也终于知道数据结构为什么能做那么大的文章了,就是容易忘记,考试两周也不能放下看算法和刷OJ;真的菜,别眼高手低了。

The Suspects 

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意就是告诉你 有m组学生在一起玩,一组中有一个疑似感染非典,其他都疑似感染非典。

并差集水题,,做好发现自己真的菜。

因为是只要输出疑似感染非典的总人数,符合并差集的思想,

复习一下并差集

用数组或者结构体表示,分为数据和父亲部分,在find函数中用数据作为参数,先找到数据所在的位置,然后去看这个数据的根节点是谁,然后是union函数,给两个数据,用两次find函数,然后依据少的并到多的原则将少数据父节点的parent指向多数据的父节点,注意要改变多数据的最终个数

并差集只能找到这个元素属于那个集合,并且告诉你这个集合有几个元素,并不能得出这个集合全部的元素,所以这边用并差集!!!!!!

AC代码

#include <set> 
#include <queue> 
#include<algorithm>
#include <iostream>
#include<string.h>
#include<map>
#include<stack>
#include<string> 
#include <stdio.h>
#include<math.h>
#include <cstring> 
#define maxint 0x3f3f3f
using namespace std;
int parent[30000];
int n,m;
int find(int i){
    for(;parent[i]>0;i=parent[i]);
    return i;
}
void Union(int i,int j){
    int pi=find(i);
    int pj=find(j);
    if(pi!=pj){//如果两个元素属于同个集合了,不用合并 
        if(parent[pi]>parent[pj]){
            parent[pj]+=parent[pi];
            parent[pi]=pj;
        }
        else {
             parent[pi]+=parent[pj];
            parent[pj]=pi;
        }
    }
}
int main()
{  
    while(cin>>n>>m){
        memset(parent,-1,sizeof(parent));
      //  cout<<parent[0]<<endl;
        if(n==0&&m==0)
            break;
        int num;
          
        for(int i=0;i<m;i++){
            cin>>num;
            int nn,temp;
            cin>>nn;
            for(int j=1;j<num;j++){
                cin>>temp;
                Union(temp,nn);
            }
        }
       // cout<<find(0)<<endl;
       // cout<<parent[-1]<<endl;
        cout<<parent[find(0)]*-1<<endl;
    } 
    
    return 0;
}

这道题数据可以直接认为是数组下标 所以就只用了parent数组。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值