intellij IDEA:Error : java 不支持发行版本xxx 的问题

  1. 配置一
    在 Setting->Java Compiler 中将 Project bytecode version 与 target bytecode version 全部设为与本地版本相同的 version 13。

  2. 配置二
    在 Project Structure->Modules->Language level 也设置成 13,与上面配置的版本一致。

3.如果Module中没有另外指定 Language level ,则在 “File”->“Project Structure”->“Project Settings”->“Project”->“Project language level:”, 选择支持的语言级别,如将支持的 13(Preview) 改成 我安装后支持的 8;
在这里插入图片描述
如果Module中有指定,则从"File"->“Project Structure”->“Project Settings”->“Modules”->“hello”->“Sources”->“Language level” 选择支持的语言级别,如将支持的 13(Preview) 改成 我安装后支持的 8;
在这里插入图片描述

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付 29.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值