Floyd 算法 POJ 1125

Stockbroker Grapevine
Time Limit: 1000MS

Memory Limit: 10000K
Total Submissions: 37682

Accepted: 20960
Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all. 
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output
3 2
3 10
Source
Southern African 2001


让我重新找回了高三做英语阅读理解的感觉!!!其实题目就是求一个图中任意一个点到其他所有点的最小距离,Floyd算法的经典题型。

以下是代码:
    #include<cstdio>
    #include<algorithm>
    #define MAX 105
    #define MAXINT 0xffff
    using namespace std;
    int map[MAX][MAX];
    int main()
    {
        int n,num,k;
        while(scanf("%d",&num)&&num){
            for(int i=0;i<MAX;i++)
                for(int j=0;j<MAX;j++)
                    {
                        if(i==j)
                            map[i][j]=0;
                        else
                            map[i][j]=MAXINT;
                    }
            int maxnum[MAX]={0};
            for(int i=1;i<=num;++i)
            {
                scanf("%d",&n);
                for(int j=1;j<=n;j++)
                {
                    scanf("%d",&k);
                    scanf("%d",&map[i][k]);
                }
            }
            for(int k=1;k<=num;++k)
                for(int i=1;i<=num;++i)
                    for(int j=1;j<=num;++j) 
                    map[i][j]=min(map[i][j],(map[i][k]+map[k][j]));//算法核心
            for(int i=1;i<=num;i++)
                {
                    maxnum[i]=0;
                    for(int j=1;j<=num;j++)
                    {
                        maxnum[i]=max(maxnum[i],map[i][j]);
                    }
                }
                int minnum=MAXINT;
                int index=1;
                for(int i=1;i<=num;i++)
                {
                    if(maxnum[i]<minnum&&maxnum[i]!=0)
                    {
                        index=i;
                        minnum=maxnum[i];
                    }   
                }
            int flag=0;
                for(int i=1;i<=num;i++)
                {
                    int isbroken=1;
                    for(int j=1;j<=num;j++)
                    {
                        if((map[i][j]<100||map[j][i]<100)&&i!=j)
                             isbroken=0;
                    }
                    if(isbroken==1)
                        flag=1;
                }
            if(flag==0)
                printf("%d %d\n",index,minnum); 
            else
                printf("disjoint\n");   
        }
        return 0;
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值