AlphaCat的PAT甲级1002AC纪念(多项式相加)

 

 

 

 

 

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 

#include<iostream>
using namespace std;
int amount=0;
void store(int cases,double a[])
{
	int index=0;double value=0;
	for(int i=0;i<cases;i++)
	{

		cin>>index;
		cin>>value;
		a[index]+=value;
	}
}

int main()
{	
	double a[2000]={};
	int cases;
	cin>>cases;
	store(cases,a);
	cin>>cases;
	store(cases,a);
	for(int i=0;i<1999;i++)
	if(a[i]!=0)
		amount++;
	cout<<amount;
	for(int i=1999;i>=0;i--)
	{
		if(a[i]!=0.0&&a[i]!=0)	printf(" %d %.1f",i,a[i]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Python实现多项式相加的一般步骤如下: 1. 定义多项式类:创建一个多项式类,用于表示和操作多项式。可以使用列表或字典等数据结构来存储多项式的系数和指数。 2. 初始化多项式:在多项式类中,定义初始化方法,将输入的多项式字符串转换为字典,其中字典的键为指数,值为系数。 3. 实现多项式相加函数:定义一个函数,接收两个多项式字典作为参数,将它们相加并返回一个新的多项式字典。 4. 输入多项式:从用户处获取两个多项式的输入,将它们转换为字典。 5. 调用多项式相加函数:将两个多项式字典作为参数传递给多项式相加函数,得到一个新的多项式字典。 6. 输出结果:从新的多项式字典中获取指定指数的系数,输出结果。 具体实现可以参考以下代码: ``` # 定义多项式类 class Polynomial: def __init__(self, poly_str): self.poly_dict = {} terms = poly_str.split(',') for term in terms: coef, exp = term.strip().split() self.poly_dict[int(exp)] = int(coef) # 实现多项式相加函数 def add_polynomials(poly1, poly2): result = {} for exp in set(poly1.keys()) | set(poly2.keys()): result[exp] = poly1.get(exp, 0) + poly2.get(exp, 0) return result # 输入多项式 poly_str1 = input("请输入第一个多项式:") poly_str2 = input("请输入第二个多项式:") x = int(input("请输入要求的指数:")) # 初始化多项式 poly1 = Polynomial(poly_str1).poly_dict poly2 = Polynomial(poly_str2).poly_dict # 调用多项式相加函数 result = add_polynomials(poly1, poly2) # 输出结果 print("结果为:", result.get(x, 0)) ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值