AlphaCat的PAT甲级1005AC纪念(水题)

水题不解释,附上题目连接内容代码

https://pintia.cn/problem-sets/994805342720868352/problems/994805519074574336

1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

 

#include<iostream>
#include<string>
using namespace std;

int main()
{
	string word[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	string a;
	cin>>a;
	if(a=="0")
	cout<<"zero";
	else
	{
		int sum=0;
	for(int i=0;a[i]!='\0';i++)
	sum+=(a[i]-'0');
	char b[100];
	int index=0;
	for(;sum!=0;)
	{
			b[index]=sum%10;
			sum/=10;
			index++;
	}
	for(int i=index-1;i>=0;i--)
	{
		if(i!=index-1)
		cout<<" ";
		cout<<word[(int)b[i]];
	}

	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值