AlphaCat的PAT甲级1007AC纪念(联机算法解决最大上升子序列)

附上题目的链接和内容:

https://pintia.cn/problem-sets/994805342720868352/problems/994805514284679168

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

int last=0;
int start=0;


int Max_sub( int a[] ,int cases)
{
    int tmp = 0, maxSum = -1;
    int temp_start=0;
    for ( int i = 0; i <cases ; i++ )
    {
        tmp += a[i];//加上数组当前的值 
        if ( tmp > maxSum )//如果大于了当前的最大,那么久把最大的赋值给maxsum 
        {
        	maxSum = tmp;
        	start=temp_start;//把当前位置储存的下标开始和结束的地方 
        	last=i;
        	
		}
            
        else if ( tmp < 0 )
        {
        	
        	tmp = 0;//当前的最大值以为已经小于0了,所以不如不加 
        	temp_start=i+1;
		}
		//这两个都没法发生说明没遇到极端情况,但是有可能后面加的,更大超过max所以应该加下一个数再来判断 
    }
    return(maxSum);
}
int main()
{
	int cases;cin>>cases;

	int *a=new int [cases];
	for(int i=0;i<cases;i++)
	cin>>a[i];
	int sum=Max_sub(a,cases);
	if(sum==-1)
	{
		cout<<"0"<<" "<<a[0]<<" "<<a[cases-1];
	}
	
	else{
	cout<<sum<<" "<<a[start]<<" "<<a[last];
	}
	return 0;
}

 注意点1

联机算法



int Max_sub( const vector<int> & a, int left, int right ) /* left right 分别指下标 */

{

    int tmp = 0, maxSum = 0;

    for ( int i = left; i <= right; i++ )

    {

        tmp += a[i];

        if ( tmp > maxSum )

            maxSum = tmp;

        else if ( tmp < 0 )

            tmp = 0;

    }

    return(maxSum);

}

这段代码是由联机算法引申的,所以背出联机算法显得尤为重要,然后就没有什么需要注意的了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值