AlphaCat的PAT甲级1009AC纪念(多项式相乘)

附上题目的链接和内容:https://pintia.cn/problem-sets/994805342720868352/problems/994805509540921344

 

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include<iostream>
#include<vector>
#include<cstdlib>
using namespace std;
typedef pair<int, float>  cobin;

int main()
{
	int k1; cin >> k1;
	vector<cobin> make1(k1);
	for (int i = 0; i < k1; i++)
	{
		cin >> make1[i].first;
		cin >> make1[i].second;
	}
	int k2; cin >> k2;
	vector<cobin>make2(k2);
	for (int i = 0; i < k2; i++)
	{
		cin >> make2[i].first;
		cin >> make2[i].second;
	}


	int expmax = make1[0].first + make2[0].first;
	vector<cobin> res(expmax+1);
	for (int i = expmax; i >= 0; i--)
	{
		res[i].second = 0;

	}

	for (int i = 0; i < k1; i++)//k1去乘k2的每一项
	{
		for (int j = 0; j < k2; j++)
		{
			int curmax = make1[i].first + make2[j].first;
			res[curmax].first = curmax;
			res[curmax].second += make1[i].second*make2[j].second;


		}
	}

	int sum=0;
	for (int i = expmax; i >=0; i--)//k1去乘k2的每一项
	{
		if (res[i].second != 0)
		{
			sum++;
		}
	}
	cout << sum;
	for (int i = expmax; i >= 0; i--)//k1去乘k2的每一项
	{
		if (res[i].second != 0)
		{
			printf(" %d %0.1f", res[i].first, res[i].second);
		}
	}
	
	
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值