POJ 1094

Sorting It All Out

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39539 Accepted: 13926

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

East Central North America 2001

大致题意:

    给出如下的相互关系(0 0结束) 要你判断是否在某一次读入后,能够判断所给关系是矛盾的,或者能找出唯一符合这样关系的组合,或是最终也无法确定他们的关系。

解题思路:

读入关系,但凡识别到三种结果中任何一种情况就直接输出。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int in[26],inn[26],n;
int mp[26][26];

int Topo(int op)
{
    int i,j,k,f = 1;
    for(i = 0; i < n; ++i)
        inn[i] = in[i];
    for(i = 0; i < n; ++i)
    {
        k = -1;
        for(j = 0; j < n; ++j)
        {
            if(!inn[j])
            {
                if(k != -1) 
                f = 0;
                k = j;
            }
        }
        j = k;
        if(j == -1) 
        return -1;
        if(op) 
        putchar('A'+j);
        inn[j]--;
        for(k = 0; k < n; ++k)
            inn[k] -= mp[j][k];
    }
    if(op)
        puts(".");
    return f;
}

int main()
{

    int f,m,i,a,b,x;
    char st[5];
    while(cin>>n>>m && n && m)
    {
        memset(mp,0,sizeof(mp));
        memset(in,0,sizeof(in));
        f = 0;
        x = -1;
        for(i = 1; i <= m; ++i)
        {
            cin>>st;
            a = st[0]-'A';
            b = st[2]-'A';
            //ab按从小到大的顺序
            if(st[1] == '>')
            {
                a += b;
                b = a-b;
                a -= b;
            }
            if(f) continue;
            mp[a][b]++;
            in[b]++;
            f = Topo(0);
            x = i;
        }
        if(!f) 
         puts("Sorted sequence cannot be determined.");
        else if(f == -1) 
         printf("Inconsistency found after %d relations.\n",x);
        else
        {
            printf("Sorted sequence determined after %d relations: ",x);
            Topo(1);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值