An incompatible version 1.1.33 of the APR based Apache Tomcat Native library is installed, while Tom

启动server,控制台报错:An incompatible version 1.1.33 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.2.6

查看原因:APR 基于Apache Tomcat版本不兼容[1.1.33],而Tomcat需要版本[1.2.6] 需要这个文件:tcnative-1.dll

官网: http://archive.apache.org/dist/tomcat/tomcat-connectors/native/

找到对应的版本:1.2.6

 

解压后,tomcat-native-1.2.6-win32-bin.zip,在bin目录下找到对应tcnative-1.dll。(32,64,根据自己计算机的基本信息进行选择)

把tcnative-1.dll放到自己jdk的bin目录下,重新启动server,启动正常。

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 游动-白 设计师:上身试试 返回首页