母函数--Holding Bin-Laden Captive!

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25558    Accepted Submission(s): 11283


 

Problem Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

 

 

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

 

 

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

 

 

Sample Input

 

1 1 3 0 0 0

 

 

Sample Output

 

4

 

 

Author

lcy

 

 

Recommend

We have carefully selected several similar problems for you:  1171 1398 2152 2082 1709 

 

题意:题目给出一些钱的数量,要求用给出的钱组合不能组成的最小钱数;
题解:直接套用母函数即可,把组合加法转化成幂的加法;

#include<stdio.h>
#include<string.h>

int c[10000],temp[10000];
int cost[3]={1,2,5};
int num[3];

int main(){
	while(scanf("%d%d%d",&num[0],&num[1],&num[2])!=EOF){
		if(num[0]==0&&num[1]==0&&num[2]==0)	break;
        //初始化 
    	int total=num[0]*1+num[1]*2+num[2]*5;
    	memset(c,0,sizeof(c));
    	memset(temp,0,sizeof(temp));
    	for(int i=0;i<=num[0];i++){
    		c[i]=1; //-->(1+x+x^2+x^3+...+x^num[0])
    	} 
    	//核心代码	
        for(int i=1;i<3;i++){
            for(int j=0;j<=total;j++){
                for(int k=0;k+j<=total&&k/cost[i]<=num[i];k+=cost[i])
				//k+j表示总金额数,它应该小于总和数
				//k/cost[i]表示k不能超过该种面值金额的数目 
                    temp[k+j]+=c[j];//模仿乘法分配率 
            }
            for(int j=0;j<=total;j++){
                c[j]=temp[j];
                temp[j]=0;
            }
        }
        //输出 
    	for(int i=1;i<=total+1;i++)
    	if(!c[i]){
    	    printf("%d\n",i);
    	    break;
    	}
   }
   return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值