1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

考堆的性质等,没什么特殊情况。

AC代码:

//include <bits/stdc++.h>
#include <set>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <time.h>
#include <string.h>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define sdddd(x,y,z,k) scanf("%d%d%d%d", &x, &y, &z, &k)
#define sddd(x,y,z) scanf("%d%d%d", &x, &y, &z)
#define sdd(x,y) scanf("%d%d", &x, &y)
#define sd(x) scanf("%d", &x)
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define per(i,a,b) for(int i=a;i>=b;i--)
//#define mp Debug(x) printf("%d\n", &x);
#define pb push_back
#define ms(x, y) memset(x, y, sizeof x)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const ll MOD = 1046513837;
const int maxn = 1e3 + 50;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
//typedef vector<ll> vec;
//typedef vector<vec> mat;
template <class T>
inline bool scan_d(T &ret) {
	char c; int sgn;
	if (c = getchar(), c == EOF) return 0;
	while (c != '-' && (c<'0' || c>'9')) c = getchar();
	sgn = (c == '-') ? -1 : 1;
	ret = (c == '-') ? 0 : (c - '0');
	while (c = getchar(), c >= '0'&&c <= '9') ret = ret * 10 + (c - '0');
	ret *= sgn;
	return 1;
}

int n;
int heap[maxn];
vector<int> tmp;
vector<vector<int> > ans;
void dfs(int inx){
    int l = inx * 2;
    int r = inx * 2 + 1;
    if( l > n && r > n){
        ans.push_back(tmp);
        return;
    }
    if(r <= n){
        tmp.push_back(heap[r]);
        dfs(r);
        tmp.pop_back();
    }
    if(l <= n){
        tmp.push_back(heap[l]);
        dfs(l);
        tmp.pop_back();
    }
}
int main() {
    cin >> n;
    rep(i, 1, n){
        cin >> heap[i];
    }
    tmp.push_back(heap[1]);
    dfs(1);
    for(auto v: ans){
        for(int i = 0; i < v.size(); ++i){
            printf("%d%c", v[i], (i == v.size() - 1)?'\n':' ');
        }
    }
    if(heap[1] > heap[2]){
        int flag = 1;
        int ll = n/2;
        for(int i = 1; i < ll; ++i){
            int l = i * 2;
            int r = i * 2 + 1;
            if(l <= n && heap[l] > heap[i]){
                flag = 0;
                break;
            }
            if(r <= n && heap[r] > heap[i]){
                flag = 0;
                break;
            }
        }
        if(flag)
            printf("Max Heap\n");
        else
            printf("Not Heap\n");
    }

    if(heap[1] < heap[2]){
        int flag = 1;
        int ll = n/2;
        for(int i = 1; i < ll; ++i){
            int l = i * 2;
            int r = i * 2 + 1;
            if(l <= n && heap[l] < heap[i]){
                flag = 0;
                break;
            }
            if(r <= n && heap[r] < heap[i]){
                flag = 0;
                break;
            }
        }
        if(flag)
            printf("Min Heap\n");
        else
            printf("Not Heap\n");
    }




	return 0;
}

/*
HZH -> PRS -> ROM 195
HZH -> PKN -> GDN -> ROM 195
HZH -> BLN -> ROM 180
*/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值