素数环 杭电1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66295    Accepted Submission(s): 28409


 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

 

Sample Input

 

6

8

 

 

Sample Output

 

Case 1: 1 4 3 2 5 6

             1 6 5 2 3 4

Case 2:  1 2 3 8 5 6 7 4

              1 2 5 8 3 4 7 6

              1 4 7 6 5 8 3 2

              1 6 7 4 3 8 5 2

 

 

#include<string.h>
#include<stdio.h>
#define M 40
int vis[M];//标记数组
int dis[M];//素数环数组
int a[M];//素数判断数组
int n;
void sushu() { //素数预处理,若数组a的下标为素数,那么a[i]=1,否则a[i]=0,
    int i,j;
    memset(a,1,sizeof(a));
    for(i=2; i<M; i++) {
        if(a[i])//不能写成a[i]==1 能力有限 不能理解 
            for(j=i+i; j<M; j+=i) //是i的倍数都不是素数
                a[j]=0;//不是素数的标记为0
    }
}
void dfs(int x) { //x表示已判断个数
    int i;
    if(x==n&&a[dis[n-1]+dis[0]])//当判断了n个数并
        //且dis[n-1]+dis[0]也是素数的的时候输出该素数环

    {
        for(i=0; i<n-1; i++)
            printf("%d ",dis[i]);
        printf("%d\n",dis[n-1]);
    } else {
        for(i=2; i<=n; i++)
            if(vis[i]&&a[dis[x-1]+i]) //判断和相邻的元素相加和是否为素数 
            {
                vis[i]=0; //符合条件,标记为0,表示该数已被使用,不可再用
                dis[x]=i;
                dfs(x+1);
                
                vis[i]=1;//回溯
            }
    }
}
int main() {
    int t=1;
    sushu();
    while(~scanf("%d",&n)) {
        memset(vis,1,sizeof(vis));      //记得每次初始化数组
        printf("Case %d:\n",t++);
        vis[1]=0;//1已经被判断了 
        dis[0]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值