【每日一题(35)】Dungeon Master POJ - 2251

45 篇文章 0 订阅
44 篇文章 0 订阅

Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
T>otal Submissions: 44032 Accepted: 16602

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S….
.###.
.##..

.


#
#

.


#
#

.

E


1 3 3
S##

E

#


0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题解

题中可以了解到,这道题是一个三维的bfs,和二维一样,只不过在二维的基础上多了一个z坐标轴。
所以在广搜时多了 z + 1 和 z - 1两个两个条件,其余的都一样。

代码

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
#define maxn 31
char mp[maxn][maxn][maxn];
bool vis[maxn][maxn][maxn];
int l,r,c,flag = 0;
struct node{
  int x,y,z,cnt;
  node(int a,int b,int c,int d){
    x = a,y = b,z = c,cnt = d;
  }
};
void bfs(int x,int y,int z){
  queue<node> q;
  node start(x,y,z,0);
  q.push(start);
  while(!q.empty()){
    node p = q.front();q.pop();
    if(p.x < l && p.x >= 0 && p.y >= 0 && p.y < r && p.z >= 0 && p.z <c){
      if(mp[p.x][p.y][p.z] == 'E'){
        flag = 1;
        printf("Escaped in %d minute(s).\n",p.cnt);
        break;
      }else if(mp[p.x][p.y][p.z] != '#' && vis[p.x][p.y][p.z] == false){
        vis[p.x][p.y][p.z] = true;
        {node temp(p.x + 1,p.y,p.z,p.cnt + 1);q.push(temp);}
        {node temp(p.x - 1,p.y,p.z,p.cnt + 1);q.push(temp);}
        {node temp(p.x,p.y + 1,p.z,p.cnt + 1);q.push(temp);}
        {node temp(p.x,p.y - 1,p.z,p.cnt + 1);q.push(temp);}
        {node temp(p.x,p.y,p.z + 1,p.cnt + 1);q.push(temp);}
        {node temp(p.x,p.y,p.z - 1,p.cnt + 1);q.push(temp);}
      }
    }
  }
}
int main()
{
  while(scanf("%d %d %d",&l,&r,&c) != EOF){
    if(!l && !r && !c) break;
    for(int i = 0;i < l; i++){
      getchar();
      for(int j = 0;j < r; j++){
        fill(vis[i][j],vis[i][j] + c + 1, false);
        gets(mp[i][j]);
      }
    }
    for(int i = 0;i < l; i++){
      for(int j = 0;j < r; j++){
        for(int k = 0;k < c; k++){
          if(mp[i][j][k] == 'S'){
            flag = 0;
            bfs(i,j,k);
            break;
          }
        }
      }
    }
    if(flag == 0) printf("Trapped!\n");
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值