【PAT A1019】General Palindromic Number

【PAT A1019】General Palindromic Number


Question Description

A number that will be the same when it is written forwards or backwards is known as a Palindromic 
Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic 
numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of 
palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in 
base b≥2, where it is written in standard notation with k+1 digits a i​​  as ∑​i=0​k​​ (a​i​​ b​i​​ ). Here, as usual, 
0≤a​i​​ <b for all i and a​k is non-zero. Then N is palindromic if and only if ai​​ =a​k−i​​  for all i. Zero is written 0 
in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic 
number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 
0<N≤10^9​​  is the decimal number and 2≤b≤10^9​​  is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in 
the next line, print N as the number in base b in the form "ak​​  a​k−1​​  ... a​0​​ ". Notice that there must be no 
extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

Reference code

#include<cstdio>
int main(){
int z[40],num=0;//数组z存放q进制数y的每一位,num为位数
int q,y;
int flag=1;
scanf("%d %d",&y,&q);
do{
	z[num++]=y%q;
	y=y/q;
}while(y!=0);
for(int i=0;i<=num/2;i++){
	if(z[i]!=z[num-1-i]){
    	flag=0;
    	break;
 	}
}
if(flag==1){
	printf("Yes\n");
}
if(flag==0){
	printf("No\n");
}
printf("%d",z[num-1]);
for(int i=num-2;i>=0;i--){
  printf(" %d",z[i]);
	}
}

Operation Result
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段代码也可以实现在一个区间内寻找回文数并计算它们的和。 其中 `isPalindromic` 函数用于判断一个数是否为回文数,`getInputs` 函数用于获取区间的上边界和下边界,并检查用户的输入是否合法。在主程序中,我们首先调用 `getInputs` 函数获取区间的上边界和下边界,然后通过循环遍历这个区间,找到其中所有回文数,并将它们存储在一个列表中。最后,我们计算这些回文数的总和,并输出结果。 这段代码的工作流程与之前的示例代码基本相同,唯一的区别是在输入区间时,代码将上边界和下边界分别存储在 `upper` 和 `lower` 变量中,并检查它们的大小关系。如果用户输入的上边界比下边界小,则交换它们的值,以确保下边界始终小于或等于上边界。 下面是这段代码的完整实现: ```python def isPalindromic(n): s = str(n) return s == s[::-1] def getInputs(): count = 0 while count < 3: try: upper = int(input("请输入区间的上边界:")) lower = int(input("请输入区间的下边界:")) if upper > lower: upper, lower = lower, upper return upper, lower except: print("输入有误,请重新输入!") count += 1 print("输入错误次数过多,程序退出!") exit() palindromic_list = [] upper, lower = getInputs() for i in range(lower, upper + 1): if isPalindromic(i): palindromic_list.append(i) total = sum(palindromic_list) print("区间[{},{}]中的回文数为:{}".format(lower, upper, palindromic_list)) print("它们的和为:{}".format(total)) ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值