window 安装 sass compass 记录

原创 2017年11月15日 11:18:18

1.安装Ruby

安装sass 和compass 需要 Ruby 的环境,还区分xp 和win7-8 下版本区别

ruby 官网中文

ruby 官网英文

注意: xp: 下载 [xp不能下载包含64位的版本,我是下载32位安装成功,但调用gem 命令直接报错,不建议使用 包含有64 区分的版本.

Ruby 1.9.3-p551

win7-8 : 2.0以上或者跟xp的一样都可以.

Ruby 2.1.5

Ruby 2.1.5 (x64)

Ruby 2.0.0-p598

Ruby 2.0.0-p598 (x64)

安装注意:全部打钩,安装在哪里都可以 [根据需求,一般默认C盘]

安装完毕, 重启 cmd , 输入 gem 命令

输出信息...
如果提示"RubyGems is a sophisticated package manager for Ruby. This is a basic help message containing pointers to more information. ",即安装成功.

下一步我们要安装 sass , 使用gem 命令...但是连接国外的地址,(呵呵,你懂的),我们换回 淘宝的gem镜像

首先把默认的删除

命令:gem sources --remove https://rubygems.org/

把淘宝的镜像设置进列表

命令:gem sources -a https://ruby.taobao.org/

查看列表

命令:gem sources -l

输出信息...
*** CURRENT SOURCES ***
https://ruby.taobao.org
# 请确保只有 ruby.taobao.org

2.安装sass

然后我们先安装sass,再安装compass

命令: gem install sass

等待....

输出信息...
Fetching: sass-3.4.9.gem (100%)
Successfully installed sass-3.4.9
1 gem installed
Installing ri documentation for sass-3.4.9...
unable to convert U+FFFD from UTF-8 to GBK for lib/sass/script/value/string.rb,
skipping
unable to convert U+FFFD from UTF-8 to GBK for lib/sass/util.rb, skipping
Installing RDoc documentation for sass-3.4.9...
unable to convert U+FFFD from UTF-8 to GBK for lib/sass/script/value/string.rb,
skipping
unable to convert U+FFFD from UTF-8 to GBK for lib/sass/util.rb, skipping

测试是否安装成功?

命令: sass -v

如果输出

Sass 3.4.9 (Selective Steve)

安装成功,接下来继续安装compass

命令: gem install compass

等待...(很漫长...慢慢等啊,看网速...)

输出信息...
Sass 3.4.9 (Selective Steve)
C:\Documents and Settings\Administrator>gem install
Fetching: multi_json-1.10.1.gem (100%)
Fetching: compass-core-1.0.1.gem (100%)
Fetching: compass-import-once-1.0.5.gem (100%)
Fetching: chunky_png-1.3.3.gem (100%)
Fetching: rb-fsevent-0.9.4.gem (100%)
Fetching: ffi-1.9.6-x86-mingw32.gem (100%)
Fetching: rb-inotify-0.9.5.gem (100%)
Fetching: compass-1.0.1.gem (100%)
Compass is charityware. If you love it, please d
//umdf.org/compass Thanks!
Successfully installed multi_json-1.10.1
Successfully installed compass-core-1.0.1
Successfully installed compass-import-once-1.0.5
Successfully installed chunky_png-1.3.3
Successfully installed rb-fsevent-0.9.4
Successfully installed ffi-1.9.6-x86-mingw32
省略一万字......

测试是否安装成功?

命令: compass -v

输出信息...
Compass 1.0.1 (Polaris)
Copyright (c) 2008-2014 Chris Eppstein
Released under the MIT License.
Compass is charityware.
Please make a tax deductable donation for a worthy cause: http://umdf.org/compass

到这里已经 把 sass,compass 都安装成功了,之后嘛.就可以愉快地使用它们了.

ps:我主要因为想学习用compass 来自动拼装雪碧图才折腾这玩意...

推荐sass,less 自动编译工具

windows下安装sass和compass

1)先安装ruby 打开命令行,输入ruby -v,如果没有安装ruby,则会显示   ’ruby’ is not recognized as an internal or external com...
  • dw1067061570
  • dw1067061570
  • 2017-02-09 14:46:47
  • 1267

SASS/Compass的安装与卸载

认识SASS/Compass SASS是一种CSS的开发工具,提供了许多便利的写法,大大节省了设计者的时间,使得CSS的开发,变得简单和可维护。Comapss:SASS的关系大致等于 JQuery:...
  • bluefish1990
  • bluefish1990
  • 2014-03-12 15:26:10
  • 23392

ruby/sass/compass安装

因为sass和compass依赖于ruby环境,所以装之前先确认装了ruby。可到官网下载最新版ruby安装包http://rubyinstaller.org/downloads/ 在安装的时候...
  • houjiyu243042162
  • houjiyu243042162
  • 2016-09-02 14:23:08
  • 1282

安装Sass和Compass

安装Sass和Compass安装Rubysass基于Ruby语言开发而成,因此安装sass前需要安装Ruby。(注:mac下自带Ruby无需在安装Ruby!)window下安装SASS首先需要安装Ru...
  • u012885276
  • u012885276
  • 2015-08-18 14:23:36
  • 802

Windows8.1 64位 安装 Ruby Sass Compass

整理了Sass,compass 和 ruby 的介绍,以及在windows8.1 下安装会出现的一些问题,供自己参考,希望对其他人也有用。 我们知道CSS是为设计师准备的工具,没有变量,也没逻辑语句,...
  • maxmahh
  • maxmahh
  • 2015-03-16 14:11:23
  • 434

Sass&Compass快速入门总结

什么是Sass?Sass是CSS预处理器的一种,其他还有less,stylus。他们的作用相同,但是语法,功能上略有差异,经过了解。我发现less相对来说更易上手,但我还是选择了功能更为强大,语法种类...
  • Creabine
  • Creabine
  • 2016-06-22 11:26:49
  • 1897

sass + compass

compass 是什么为什么要学习 compass compass 详解写在前面:sass 是 css 预编译语言,使用 sass 在团队合作和项目管理上有很大的优势,所以,目前使用广泛。关于 sa...
  • csdn_yudong
  • csdn_yudong
  • 2017-07-26 13:59:48
  • 796

win10下安装sass环境遇到的问题

第一步:Ruby环境安装 问题1、如何下载Ruby安装包?http://rubyinstaller.org/downloads/下载对应系统版本的安装包;然后双击rubyinstaller-2.3....
  • shakdy
  • shakdy
  • 2016-11-12 13:01:51
  • 1400

Sass&Compass安装和使用

Sass的安装: 1.安装:SASS是Ruby语言写的,但是两者的语法没有关系。不懂Ruby,照样使用。只是必须先安装Ruby,然后再安装SASS。 假定你已经安装好了Ruby,接着在命令行输入下...
  • github_22022001
  • github_22022001
  • 2015-04-09 15:49:43
  • 401

mac版本webstorm配置compass的两种方法

最近使用compass,发现网上大部分教程都太老了或者不太清楚,决定自己总结一篇webstorm配置compass 方法一 使用命令行 1、创建compass compass create c...
  • wangdajiao
  • wangdajiao
  • 2017-05-31 18:17:12
  • 1310
收藏助手
不良信息举报
您举报文章:window 安装 sass compass 记录
举报原因:
原因补充:

(最多只允许输入30个字)