2018ACM-CCPC湖南湘潭邀请赛 A Easy h-index

Easy h-index

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
比赛题目:
http://acm.hdu.edu.cn/downloads/2018ccpc_hn.pdf

The h-index of an author is the largest h where he has at least h papers with citations not less than h.

Bobo has published many papers.
Given a0,a1,a2,,an which means Bobo has published ai papers with citations exactly i, find the h-index of Bobo.

 

Input
The input consists of several test cases and is terminated by end-of-file.

The first line of each test case contains an integer n.
The second line contains (n+1) integers a0,a1,,an.
 

Output
For each test case, print an integer which denotes the result.

## Constraint

* 1n2105
* 0ai109
* The sum of n does not exceed 250,000.
 

Sample Input
 
 
11 221 2 330 0 0 0

Sample Output
 
 
120
//有i篇影响因子为a[i]的论文

#include <bits/stdc++.h>
using namespace std;
int a[200005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            scanf("%d",&a[i]);
        int sum=0;
        int i;
        for(i=n;i>=0;i--)
        {
            sum=sum+a[i];
            if(sum>=i)
                break;
        }
        printf("%d\n",i);
    }
    return 0;
}


Sample Output
 
  
120
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值