【数学】POJ - 1971 E - Parallelogram Counting

E - Parallelogram Counting  POJ - 1971 

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case. 
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000. 

Output

Output should contain t lines. 
Line i contains an integer showing the number of the parallelograms as described above for test case i. 

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6

题意:
输入n个点的坐标,找出能组成多少个平行四边形。
思路:
用平行四边形的对角线交点是两对角线的中点这一性质解题(如有两条直线中点坐标相同则能组成一个平行四边形)。值得注意的是有多对直线有相同中点的情况时要算出实际的数目sum+=(ans-1)*ans/2,其中ans是满足性质直线的个数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1005;
struct node
{
    int x,y;
}a[maxn],mid[550000];
bool cmp(const node &a1,const node &b1)
{
    if(a1.x!=b1.x) return a1.x<b1.x;
    else return a1.y<b1.y;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
        int num=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                mid[++num].x=a[j].x+a[i].x,mid[num].y=a[j].y+a[i].y;
            }
        }
        sort(mid+1,mid+1+num,cmp);

        int ans=1,sum=0;
        for(int i=1; i<num; i++)
        {
            if(mid[i].x==mid[i+1].x&&mid[i].y==mid[i+1].y) ans++;
            else
            {
                sum=sum+(ans-1)*ans/2;   // 转化为能组成的平行四边形的个数
                ans=1;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值