求最短距离及其花费(hdu 3790) (Dijkstra + 优先队列)

最短路径问题

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 32   Accepted Submission(s) : 14

Problem Description

给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。

Input

输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。 (1<n<=1000, 0<m<100000, s != t)

Output

输出 一行有两个数, 最短距离及其花费。

Sample Input

3 2 1 2 5 6 2 3 4 5 1 3 0 0

Sample Output

9 11

Source

浙大计算机研究生复试上机考试-2010年

 

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int e;
    int w;
    int cost;
};
struct cmp
{
    bool operator()(const node &a,const node &b)
    {
        if(a.w!=b.w)
            return a.w>b.w;
        else
            return a.cost>b.cost;
    }
};
int main()
{
    int n,m,s,t;
    while(scanf("%d%d",&n,&m)==2&&(n||m))
    {
        priority_queue<node,vector<node>,cmp>que;
        vector<node>v[1001];
        int vis[1001]={0};
        node x;
        while(m--)
        {
            int a,b,d,p;
            scanf("%d %d %d %d",&a,&b,&d,&p);
            x.e=b,x.w=d,x.cost=p;
            v[a].push_back(x);
            x.e=a;
            v[b].push_back(x);
        }
        scanf("%d%d",&s,&t);
        x.e=s,x.w=0,x.cost=0;
        que.push(x);
        while(!que.empty())
        {
            x=que.top(),que.pop();
            vis[x.e]=1;
            if(x.e==t)
                break;
            for(int i=0,j=v[x.e].size(); i<j; i++)
            {
                node q;
                q.e=v[x.e][i].e;
                if(vis[q.e])
                    continue;
                q.w=x.w+v[x.e][i].w;
                q.cost=x.cost+v[x.e][i].cost;
                que.push(q);
            }
        }
        printf("%d %d\n",x.w,x.cost);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值