1027 Colors in Mars (20 分) 部分正确

  1. 审题
  2. 输入边界值,调试

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

 正确答案

#include<cstdio>
const int rad=13;
int main()
{
	int a[3];
	int b[3][100];
	int n[3]={0};
	char c[15];	c[10]='A',c[11]='B',c[12]='C';
	
	scanf("%d%d%d",&a[0],&a[1],&a[2]);
	for(int i=0; i<3; i++) {
		do {
			b[i][n[i]++] = a[i]%rad;
			a[i]=a[i]/rad;
		} while(a[i] > 0);
	}
	printf("#");
	for(int i=0; i<3; i++)	{
		if(n[i] == 1) printf("0");
		for(int j=n[i]-1; j>=0; j--)	{
			if(b[i][j] == 10 || b[i][j] == 11 || b[i][j] == 12)
				printf("%c",c[b[i][j]]);
			else {
				printf("%d",b[i][j]);	
			}	
		}
	}
	return 0;
}

 

#include<cstdio>
const int rad=13;
int main()
{
	int a[3];
	int b[3][2];
	char c[15];	c[10]='A',c[11]='B',c[12]='C';
	
	scanf("%d%d%d",&a[0],&a[1],&a[2]);
	for(int i=0; i<3; i++) {
		int n=0;
		do {
			b[i][n++] = a[i]%rad;
			a[i]=a[i]/rad;
		} while(a[i] > 0);
	}
	printf("#");
	for(int i=0; i<3; i++)	{
		for(int j=1; j>=0; j--)	{
			if(b[i][j] == 10 && b[i][j] == 11 && b[i][j] == 12)
				printf("%c",c[ b[i][j] ]);
			printf("%d",b[i][j]);
		}
	}
	return 0;
	
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值