PATA1093:count PAT's

问题描述

1093 Count PAT’s (25分)
The string APPAPT contains two PAT’s as substrings.
The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10^5 characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string.
Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

解法一:

  1. 首先定位到第一个’P’所在的位置start
  2. 从start处开始,往后碰到一个’P’则让count_p加一;每碰到一个’A’则让count_pa加上count_p,即能构成的PA串翻倍;每碰到一个’T’则让count加上count_pa,表示能构成的PAT串翻倍。
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
	string s;
	cin>>s;
	long long count_p=0,count_pa=0;	//count_p表示A前面P的个数,count_pa表示T前面可以构成P A的个数 
	long long count=0;//count表示可以构成PAT的个数
	for(long long i=s.find('P');i<s.size();i++)
	{
		if(s[i]=='P')	count_p++;
		else if(s[i]=='A')	count_pa+=count_p;
		else if(s[i]=='T')	count+=count_pa;
	}
	cout<<count%1000000007;
	return 0;
}

解法二:

  1. 定义一个数组pre,其中pre[i]表示第i位及其之前的‘P’的个数;定义一个数组after,其中after[i]表示第i位及其之后的‘T’的个数。将两个数组初始化为0
  2. 第一次检索,如果检索到P,则pre[i]=pre[i-1]+1,否则pre[i]=pre[i-1];如果检索到’T’则after[i]=after[i+1]+1,否则after[i]=after[i+1]。
  3. 第二次检索,每检索到A就让count加上 pre[i]*after[i]。
#include<iostream>
#include<cstring>
#include<stdlib.h>
using namespace std;
int main()
{
	string s;
	cin>>s;
	long long pre[100005],after[100005];//pre保存每一位及其之前P的个数 ;after保存每一位及其之后T的个数 
	memset(pre,0,sizeof(pre));
	memset(after,0,sizeof(after));
	long long count=0;	//构成PAT串的个数
	if(s[0]=='P')	pre[0]=1;
	if(s[s.size()-1]=='T')	after[s.size()-1]=1;	//边界条件 
	for(long long i=1;i<s.size();i++)
	{
		if(s[i]=='P')	pre[i]=pre[i-1]+1;
		else	pre[i]=pre[i-1];
		if(s[s.size()-1-i]=='T')	after[s.size()-1-i]=after[s.size()-i]+1;	
		else after[s.size()-1-i]=after[s.size()-i];
	} 
	for(long long i=1;i<s.size()-1;i++)
	{
		if(s[i]=='A')	count+=pre[i]*after[i];
	}
	cout<<count%1000000007;
	return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值