【POJ - 2631】Roads in the North (树的直径,模板)

35 篇文章 0 订阅
27 篇文章 0 订阅

题干:

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

解题报告:

   这题有好多地方是容易错的,bfs中的maxx和retp不能不赋值,不然就会wa!想想也是,极限情况,只有一个点,或者是空图,总之可以构造出一个让他根本进不去那些循环的,或者进不去那个while的,所以需要初始化!这也是为什么w=maxx那句不能放到注释的那里。

AC代码:

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int MAX = 2e5 + 5 ; 
const int INF = 0x3f3f3f3f;
struct Node {
	int to;
	int w;
	int ne;
} e[MAX];
struct point {
	int pos,c;
	point(){}//没有此构造函数不能写  node t  这样
	point(int pos,int c):pos(pos),c(c){}//可以写node(pos,cost)这样

};
int head[MAX];
int cnt = 0 ;
bool vis[MAX];
void init() {
	cnt = 0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w) {
	e[cnt].to = v;
	e[cnt].w = w;
	e[cnt].ne = head[u];
	head[u] = cnt;
	cnt++;  
} 

int bfs(int x,int &w) {
	queue <point> q;
	int maxx = 0;
	int retp = x ;//返回的点坐标 
	memset(vis,0,sizeof(vis) );
	q.push(point(x,0));vis[x] = 1;
	point now;
	while(q.size() ) {
		point cur = q.front();
		q.pop();
		for(int i = head[cur.pos]; i!=-1; i=e[i].ne) {
			if(vis[e[i].to]) continue;
			vis[e[i].to] = 1;
			now.pos = e[i].to;
			now.c = cur.c + e[i].w;
			if(now.c>maxx) {
				maxx = now.c;
				retp = now.pos;
			}
			q.push(now);
		}
		//w = maxx;
		
	}
	w = maxx;
	return retp;
}
int main()
{
	init();
	int u,v,w;
	while(~scanf("%d%d%d",&u,&v,&w) ) {
		add(u,v,w);
		add(v,u,w);
	}
	int ans1 = 0,ans2 = 0;
	u = bfs(1,ans1);
	v = bfs(u,ans2);
	printf("%d\n",ans2);
	
	return 0 ;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值