xynuoj 对称排序

1971: 对称排序

时间限制: 1 Sec  内存限制: 64 MB
提交: 5  解决: 2
您该题的状态:已完成
[提交][状态][讨论版]

题目描述

In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 

输入

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, NOT SORTED. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

输出

For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output. If length of two strings is equal,arrange them as the original order.(HINT: StableSort recommanded)

样例输入

<span style="color:#333333"><span style="color:black">7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0</span></span>

样例输出

<span style="color:#333333"><span style="color:black">SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill</span></span>

提示

 

来源

nyoj语言入门 

#include<stdio.h>
#include<string.h>
int main()
{
    int n;
    int i,j,t=1;
    while(~scanf("%d",&n))
    {
        if(n==0)
        break;
        char a[n][30];
        char b[30];
        for(i=0;i<n;i++)
        scanf("%s",a[i]);
        for(i=0;i<n-1;i++)
        for(j=0;j<n-1-i;j++)
        if(strlen(a[j])>strlen(a[j+1]))
        {
            strcpy(b,a[j]);
            strcpy(a[j],a[j+1]);
            strcpy(a[j+1],b);
        }
        //for(i=0;i<n;i++)
        //printf("%s\n",a[i]);
        printf("SET %d\n",t);
        for(i=0;i<n;i+=2)
        printf("%s\n",a[i]);
        if(n%2==0)
        {
            for(i=n-1;i>0;i-=2)
            printf("%s\n",a[i]);
            
        }
        else
        {
             for(i=n-2;i>0;i-=2)
             printf("%s\n",a[i]);
        }
        t++; 
    }
    return 0;
 } 

 

 

这道题是我的耻辱,我连冒泡排序都忘了,

结题思路:先排序,在输出,先输出0,2,4,6.....,再判断字符串有几个,若为奇数,则从奇数-2开始倒着输出;否则从个数-1开始输出。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值