[C++] 1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

 

Sample Output:

3 3 3.6 2 6.0 1 1.6

这道题着实花费了点力气,各种打补丁,不过通过这道题进一步了解了map的使用方法,也不失为一件好事。

#include <iostream>
#include <vector>
#include <map>
using namespace std;
struct node{
	double coe;
	int exp;
};
int main() {
    int n, m;
    map<int, double> mapp;
	scanf("%d", &n);
	vector<node> vn(n);
    for (int i = 0; i < n; i++) 
    	scanf("%d %lf", &vn[i].exp, &vn[i].coe);
	scanf("%d", &m);
	int e;
	double c;
	for (int i = 0; i < m; i++) {
		scanf("%d %lf", &e, &c);
		for (int j = 0; j < n; j++) {
			int t = vn[j].exp + e;
			mapp[t] += (c * vn[j].coe);		//map不必先判断是否存在 
			if (mapp[t] == 0) mapp.erase(t); 
		}
	}	
	printf("%d", mapp.size());
	for (auto it = mapp.rbegin(); it != mapp.rend(); it++) {		//map的遍历,rbegin/begin 
			printf(" %d %.1lf", it->first, it->second); 
	}
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值