Ubiquitous Religions

10 篇文章 0 订阅
3 篇文章 0 订阅

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

当今世界上有许多不同的宗教,很难跟踪它们。您有兴趣了解您所在大学的学生有多少信仰。

你知道你的大学里有n名学生(0 <n <= 50000)。你不可能向每个学生询问他们的宗教信仰。此外,许多学生不愿意表达他们的信仰。避免这些问题的一种方法是询问m(0 <= m <= n(n-1)/ 2)对学生,并询问他们是否相信同一宗教(例如,他们可能知道他们是否都参加同一宗教教会)。根据这些数据,您可能不知道每个人的信仰,但您可以了解校园中可能有多少种不同宗教的上限。您可以假设每个学生最多订阅一种宗教。
输入
输入包含许多案例。每个案例都以一行指定整数n和m开头。接下来的m行每行包含两个整数i和j,指定学生i和j相信同一宗教。学生编号为1到n。输入的结束由n = m = 0的行指定。
产量
对于每个测试用例,在一行上打印案例编号(从1开始),然后是大学学生所信仰的不同宗教的最大数量。

找爸爸问题,输出分支数量即可,即为掌门的数量

code:

#include<iostream>
#include<set>
using namespace std;
const int maxn = 5e4+10;
int pre[maxn];
int find(int x){//return par[x]==x?x:par[x]=Find(par[x]);
	int son=x;
	while(x!=pre[x]){
		x=pre[x];
	}
	while(x!=son){
		int tmp=pre[son];
		pre[son]=x;
		son=tmp;
	}
	return x;
}
void join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy) pre[fx]=fy;
}
int main(){
	int n,m,a,b,q=1;
	while(cin>>n>>m,n||m){
		set <int> se;
		se.clear();
		for(int i=1;i<=n;i++) pre[i]=i;
		for(int i=0;i<m;i++){
			scanf("%d%d",&a,&b);
			if(find(a)!=find(b)){
				join(a,b);
			}
		}
		for(int i=1;i<=n;i++){
			se.insert(find(i));
		}
		cout<<"Case "<<q++<<": "<<se.size()<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值