Aizu - DPL_1_D Longest Increasing Subsequence dp+二分查找 最长递增子序列

For a given sequence A = {a0, a1, ... , an-1}, find the length of the longest increasing subsequnece (LIS) in A.

An increasing subsequence of A is defined by a subsequence {ai0, ai1, ... , aik} where 0 ≤ i0 < i1 < ... < ik < n and ai0 < ai1 < ... < aik.

Input

n
a0
a1
:
an-1

In the first line, an integer n is given. In the next n lines, elements of A are given.

Output

The length of the longest increasing subsequence of A.

Constraints

  • 1 ≤ n ≤ 100000
  • 0 ≤ ai ≤ 109

Sample Input 1

5
5
1
3
2
4

Sample Output 1

3

 

Sample Input 2

3
1
1
1

Sample Output 2

1

n^2复杂度的算法过不了此题。。。

需要dp+二分过。。。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=100005;
int n;
int a[maxn];
int dp[maxn];
int Max;
void init()
{
   Max=1;
   dp[0]=a[0];
}
int main()
{
    scanf("%d",&n);
    for (int i=0;i<n;i++)
        scanf("%d",&a[i]);
    init();
    for (int i=1;i<n;i++)
    {
        if(dp[Max-1]<a[i])
            dp[Max++]=a[i];
        else
            *lower_bound(dp,dp+Max,a[i])=a[i];
    }
    printf("%d\n",Max);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值